aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset/fbset_2.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-20 05:03:09 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:58:03 +0100
commit484fbf697925b116083925efdca211938e797c0f (patch)
treec1532a765ae713f9aa2fea80eae5082b5f16e55a /meta-oe/recipes-support/fbset/fbset_2.1.bb
parent9cf9d864d57d2b431ad9c0a78c72e335451abe5b (diff)
downloadmeta-openembedded-contrib-484fbf697925b116083925efdca211938e797c0f.tar.gz
fbset: Fix out of tree builds ( S != B )
Remove assumption about glibc == linux Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fbset/fbset_2.1.bb')
-rw-r--r--meta-oe/recipes-support/fbset/fbset_2.1.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset_2.1.bb b/meta-oe/recipes-support/fbset/fbset_2.1.bb
index 18559326a1..cbbe6caeee 100644
--- a/meta-oe/recipes-support/fbset/fbset_2.1.bb
+++ b/meta-oe/recipes-support/fbset/fbset_2.1.bb
@@ -16,15 +16,16 @@ PR = "r4"
SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
file://makefile.patch \
file://fbset-2.1-fix-makefile-dep.patch \
+ file://0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch \
"
inherit update-alternatives
do_install() {
install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5
- install -m 0755 ${WORKDIR}/${BP}/fbset ${D}${sbindir}/fbset.real
- install -m 0644 ${WORKDIR}/${BP}/*.5 ${D}${datadir}/man/man5
- install -m 0644 ${WORKDIR}/${BP}/*.8 ${D}${datadir}/man/man8
+ install -m 0755 ${B}/fbset ${D}${sbindir}/fbset.real
+ install -m 0644 ${B}/*.5 ${D}${datadir}/man/man5
+ install -m 0644 ${B}/*.8 ${D}${datadir}/man/man8
}
ALTERNATIVE_fbset = "fbset"