aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/espeak/espeak_1.48.04.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-05-18 13:32:13 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:41 +0200
commite2bd3e64d97d351a5ae61970e8507f0f5b547586 (patch)
tree238f0352dfafcd0c314951bb62ef8774f610a32f /meta-oe/recipes-support/espeak/espeak_1.48.04.bb
parentab1c74fcd0f468e8de56888dc0ebe0bd139eb06f (diff)
downloadmeta-openembedded-contrib-e2bd3e64d97d351a5ae61970e8507f0f5b547586.tar.gz
espeak, espeak-data: Update to 1.48.04 release
Disable audio codecs Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/espeak/espeak_1.48.04.bb')
-rw-r--r--meta-oe/recipes-support/espeak/espeak_1.48.04.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/espeak/espeak_1.48.04.bb b/meta-oe/recipes-support/espeak/espeak_1.48.04.bb
new file mode 100644
index 0000000000..552f40413b
--- /dev/null
+++ b/meta-oe/recipes-support/espeak/espeak_1.48.04.bb
@@ -0,0 +1,41 @@
+require espeak.inc
+inherit siteinfo
+
+EXTRA_PHONEMES = '${@bb.utils.contains("SITEINFO_ENDIANNESS", "be", "espeak-data (= ${PV})", "", d)}'
+RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}"
+
+CXXFLAGS += "-DUSE_PORTAUDIO"
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+FILES_${PN} += "${datadir}/espeak-data"
+
+do_configure() {
+ # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
+ cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+}
+
+do_compile() {
+ cd src
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}/espeak
+ install -d ${D}${datadir}/espeak-data
+
+ # we do not ship "speak" binary though.
+ install -m 0755 ${S}/src/espeak ${D}${bindir}
+ install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}/espeak/
+ ln -sf espeak/espeak.h ${D}${includedir}/
+ oe_libinstall -so -C src libespeak ${D}${libdir}
+
+ if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
+ # the big-endian phon* files are provided by the package espeak-data
+ rm -f ${S}/espeak-data/phon*
+ fi
+
+ cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
+ chown -R root:root ${D}${datadir}/espeak-data
+}