aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/enca/enca_1.9.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-24 10:47:43 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-24 16:24:20 +0200
commit613e7230316023cadb97179b1d3b2ffecdb83207 (patch)
treee39c20671dea0a2fac3f82158e603807e7e8f19c /meta-oe/recipes-support/enca/enca_1.9.bb
parent6da6b34ddf9d7c3f72a9c9be4884a4bb5fe3a504 (diff)
downloadmeta-openembedded-contrib-613e7230316023cadb97179b1d3b2ffecdb83207.tar.gz
enca 1.9: import from OE classic
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/enca/enca_1.9.bb')
-rw-r--r--meta-oe/recipes-support/enca/enca_1.9.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/enca/enca_1.9.bb b/meta-oe/recipes-support/enca/enca_1.9.bb
new file mode 100644
index 0000000000..5472af4e59
--- /dev/null
+++ b/meta-oe/recipes-support/enca/enca_1.9.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Enca is an Extremely Naive Charset Analyser"
+SECTION = "libs"
+HOMEPAGE = "http://trific.ath.cx/software/enca/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=24b9569831c46d4818450b55282476b4"
+
+SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/enca-${PV}.tar.bz2 \
+ file://configure-hack.patch \
+ file://dont-run-tests.patch \
+ file://configure-remove-dumbness.patch \
+ file://makefile-remove-tools.patch "
+
+SRC_URI[md5sum] = "b3581e28d68d452286fb0bfe58bed3b3"
+SRC_URI[sha256sum] = "02acfef2b24a9c842612da49338138311f909f1cd33933520c07b8b26c410f4d"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-libiconv-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
+
+do_configure_prepend() {
+ # remove failing test which checks for something that isn't even used
+ sed -i -e '/ye_FUNC_SCANF_MODIF_SIZE_T/d' configure.ac
+}
+
+do_configure_append() {
+ sed -i s:-I/usr/include::g Makefile
+ sed -i s:-I/usr/include::g */Makefile
+}
+
+do_compile() {
+ cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c
+ cd ..
+ oe_runmake
+}
+