aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/edac-utils/edac-utils_git.bb
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-12-02 17:51:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:42:08 +0100
commit49e6d6103e35e1646674c6fd7e70c387b1b127b4 (patch)
treec263109e50beb42f4bf3bed9d66a892b57f5b71b /meta-oe/recipes-support/edac-utils/edac-utils_git.bb
parent30f03b584a0ef569c5a431e66a6d910246dd2d4f (diff)
downloadmeta-openembedded-contrib-49e6d6103e35e1646674c6fd7e70c387b1b127b4.tar.gz
edac-utils: add patches for initscript
Update LIC_FILES_CHKSUM that the whole license file should be used rather than the first 2 lines. Remove COMPATIBLE_HOST that edac-utils could build for all architectures. Update runtime dependencies: * add perl modules that edac-ctl needs * add dmidecode for the archs which are in COMPATIBLE_HOST of dmidecode that dmidecode is required by command edac-ctl. And add patches for initscripts to: * add restart subcommand * make init script be able to load EDAC module automatically Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/edac-utils/edac-utils_git.bb')
-rw-r--r--meta-oe/recipes-support/edac-utils/edac-utils_git.bb19
1 files changed, 14 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/edac-utils/edac-utils_git.bb b/meta-oe/recipes-support/edac-utils/edac-utils_git.bb
index e5621ade6a..9bd2f0ae97 100644
--- a/meta-oe/recipes-support/edac-utils/edac-utils_git.bb
+++ b/meta-oe/recipes-support/edac-utils/edac-utils_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "Userspace helper for Linux kernel EDAC drivers"
HOMEPAGE = "https://github.com/grondo/edac-utils"
SECTION = "Applications/System"
LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;beginline=1;endline=2;md5=1fbd81241fe252ec0f5658a521ab7dd8"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = " sysfsutils"
@@ -11,7 +11,10 @@ PV = "0.16+git${SRCPV}"
S = "${WORKDIR}/git"
-SRC_URI = "git://github.com/grondo/edac-utils;protocol=http"
+SRC_URI = "git://github.com/grondo/edac-utils \
+ file://make-init-script-be-able-to-automatically-load-EDAC-.patch \
+ file://add-restart-to-initscript.patch \
+"
inherit autotools-brokensep
@@ -20,6 +23,12 @@ do_configure_prepend () {
${S}/bootstrap
}
-COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
-
-RDEPENDS_${PN} = " perl"
+RDEPENDS_${PN}_x86 = "dmidecode"
+RDEPENDS_${PN}_x86-64 = "dmidecode"
+RDEPENDS_${PN}_arm = "dmidecode"
+RDEPENDS_${PN}_aarch64 = "dmidecode"
+RDEPENDS_${PN}_powerpc = "dmidecode"
+RDEPENDS_${PN}_powerpc64 = "dmidecode"
+RDEPENDS_${PN}_append = " \
+ perl-module-file-basename perl-module-file-find perl-module-getopt-long perl-module-posix \
+"