aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/dfu-util
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-19 08:42:51 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-19 13:56:59 -0800
commita597de10ea52ce415a41ff1f3864967b302e97c7 (patch)
treef4046a893b941d6b329aa3bef7e581a3e916cd4d /meta-oe/recipes-support/dfu-util
parent989b67be6d0fcadfd3ab52d27663a06c1e8f61ca (diff)
downloadmeta-openembedded-contrib-a597de10ea52ce415a41ff1f3864967b302e97c7.tar.gz
dfu-util-native,sjf2410-linux-native: Fix Deploy in multimachine builds
When more than two machine are built using same tmpdir and happen to use these tools the builds fail Fixes ERROR: The recipe dfu-util-native is trying to install files into a shared area when those files already exist. Those files and their manifest location are: TOPDIR/build/tmp/deploy/tools/dfu-util-0.9 (matched in manifest-qemumips-dfu-util-native.deploy) Please verify which recipe should provide the above files. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/dfu-util')
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
index 76faefefbb..feb16fa730 100644
--- a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
+++ b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
@@ -8,7 +8,6 @@ PACKAGECONFIG ??= ""
PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
-do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
do_deploy() {
install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
rm -f ${DEPLOYDIR}/dfu-util
@@ -16,3 +15,11 @@ do_deploy() {
}
addtask deploy before do_package after do_install
+
+do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
+# cleandirs should possibly be in deploy.bbclass but we need it
+do_deploy[cleandirs] = "${DEPLOYDIR}"
+# clear stamp-extra-info since MACHINE_ARCH is normally put there by
+# deploy.bbclass
+do_deploy[stamp-extra-info] = ""
+