aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-09-08 22:46:00 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-08 21:29:52 -0700
commitb8f5484fd8900900b5af7fbade631bf35c35c0f9 (patch)
treeb9d62bdd171d2716bb679f8c25621605783a0f1b /meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
parent17aca2cf9dbd59faa3f0bcadb5e0defc418266bc (diff)
downloadmeta-openembedded-contrib-b8f5484fd8900900b5af7fbade631bf35c35c0f9.tar.gz
dfu-util: upgrade 0.10 -> 0.11
o Fix suffix check regression on Windows with Large File Support o Skip setting alternate interface when not needed o Only clamp transfer size on Linux o Quirk for GD32 leave request o Improve status and error messages and exit codes o dfuse: Process all alternate interfaces in a DfuSe file o dfuse-pack.py: Fix alternate settings if first is 0 2021-09-05 Tormod Volden <debian.tormod@gmail.com> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb')
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
new file mode 100644
index 0000000000..4641b0181a
--- /dev/null
+++ b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.11.bb
@@ -0,0 +1,24 @@
+require dfu-util_${PV}.bb
+
+inherit deploy native
+
+DEPENDS = "libusb1-native"
+
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
+
+do_deploy() {
+ install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
+ rm -f ${DEPLOYDIR}/dfu-util
+ ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
+}
+
+addtask deploy before do_package after do_install
+
+# cleandirs should possibly be in deploy.bbclass but we need it
+do_deploy[cleandirs] = "${DEPLOYDIR}"
+# clear stamp-extra-info since MACHINE_ARCH is normally put there by
+# deploy.bbclass
+do_deploy[stamp-extra-info] = ""
+