aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-09 17:52:26 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:31:59 +0200
commit7c25fa41fa40f74e36ff487c2ba0c857263093dd (patch)
tree21500565b7c7a7dbe40bf6681e134f724193d074 /meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch
parent5f9728d97f65173833f9d9aa2f535172f222c844 (diff)
downloadmeta-openembedded-contrib-7c25fa41fa40f74e36ff487c2ba0c857263093dd.tar.gz
daemonize: update to version 1.7.7
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch')
-rw-r--r--meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch b/meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch
new file mode 100644
index 0000000000..4fa2ee1b3b
--- /dev/null
+++ b/meta-oe/recipes-support/daemonize/files/fix-ldflags-for-gnuhash.patch
@@ -0,0 +1,23 @@
+Add the LDFLAGS to the final link to avoid errors with missing GNU_HASH
+
+Upstream-Status: Submitted [https://github.com/bmc/daemonize/pull/22]
+
+Signed-off-by: Derek Straka <derek@asterius.io>
+
+diff --git a/Makefile.in b/Makefile.in
+index 8a4d078..40d3dee 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -24,10 +24,10 @@ LDFLAGS = @LDFLAGS@
+ all: daemonize
+
+ daemonize: daemonize.o getopt.o $(MISSING_OBJECTS)
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ testdaemon: testdaemon.o
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+ psman: daemonize.ps
+