aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/colord
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-support/colord
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/colord')
-rw-r--r--meta-oe/recipes-support/colord/colord-native.bb2
-rw-r--r--meta-oe/recipes-support/colord/colord.bb8
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/colord/colord-native.bb b/meta-oe/recipes-support/colord/colord-native.bb
index 845041cc43..65fa0f44b0 100644
--- a/meta-oe/recipes-support/colord/colord-native.bb
+++ b/meta-oe/recipes-support/colord/colord-native.bb
@@ -1,6 +1,6 @@
require ${BPN}.inc
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}-native:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}-native:"
inherit meson native
diff --git a/meta-oe/recipes-support/colord/colord.bb b/meta-oe/recipes-support/colord/colord.bb
index f514c0b782..66dc4a5802 100644
--- a/meta-oe/recipes-support/colord/colord.bb
+++ b/meta-oe/recipes-support/colord/colord.bb
@@ -4,7 +4,7 @@ inherit meson gobject-introspection gsettings gettext bash-completion systemd fe
# polkit and gobject-introspection are mandatory and cannot be configured
REQUIRED_DISTRO_FEATURES = "polkit gobject-introspection-data"
-UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
+UNKNOWN_CONFIGURE_WHITELIST:append = " introspection"
DEPENDS += " \
${BPN}-native \
@@ -28,9 +28,9 @@ EXTRA_OEMESON = " \
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
-SYSTEMD_SERVICE_${PN} = "colord.service"
+SYSTEMD_SERVICE:${PN} = "colord.service"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/dbus-1 \
${datadir}/polkit-1 \
${datadir}/glib-2.0 \
@@ -42,4 +42,4 @@ FILES_${PN} += " \
"
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"
+USERADD_PARAM:${PN} = "--system --user-group -d /var/lib/colord -s /bin/false colord"