aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cli11
diff options
context:
space:
mode:
authorWilliam A. Kennington III via Openembedded-devel <openembedded-devel@lists.openembedded.org>2019-01-15 16:48:56 -0800
committerKhem Raj <raj.khem@gmail.com>2019-01-15 22:08:47 -0800
commitd183435dac7301100e6f359e1aa6ccf8b5d25645 (patch)
tree1f03d8f7b5963b91f9d31953c904d46ccf485f7c /meta-oe/recipes-support/cli11
parent9e669a4cbcb1a14406f349f70c0ab7a2a1604138 (diff)
downloadmeta-openembedded-contrib-d183435dac7301100e6f359e1aa6ccf8b5d25645.tar.gz
cli11: Add recipe
cli11 is a c++ command line parser library that provides a simple user interface with modern c++ semantics. Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cli11')
-rw-r--r--meta-oe/recipes-support/cli11/cli11_1.6.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cli11/cli11_1.6.2.bb b/meta-oe/recipes-support/cli11/cli11_1.6.2.bb
new file mode 100644
index 0000000000..6899b1264b
--- /dev/null
+++ b/meta-oe/recipes-support/cli11/cli11_1.6.2.bb
@@ -0,0 +1,16 @@
+SUMMARY = "C++11 command line parser"
+DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface."
+HOMEPAGE = "https://github.com/CLIUtils/CLI11"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c271fee3ae28e11b24b97284d9f82887"
+SRCREV = "bd4dc911847d0cde7a6b41dfa626a85aab213baf"
+PV .= "+git${SRCPV}"
+
+SRC_URI += "gitsm://github.com/CLIUtils/CLI11"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+inherit ptest
+
+DEPENDS += "boost"