aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
diff options
context:
space:
mode:
authorWilliam A. Kennington III via Openembedded-devel <openembedded-devel@lists.openembedded.org>2019-07-09 15:15:38 -0700
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:28:20 -0700
commit583ffd416c17fba04345d9ba6cad1001e1509eb6 (patch)
tree7a1208ada832613f6ad2b1005561cf0473883f1f /meta-oe/recipes-support/cli11/cli11_1.8.0.bb
parent75b516de736bc8d26c733756d94c48ab9fd09eb3 (diff)
downloadmeta-openembedded-contrib-583ffd416c17fba04345d9ba6cad1001e1509eb6.tar.gz
cli11: 1.7.1 -> 1.8.0
Signed-off-by: William A. Kennington III <wak@google.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cli11/cli11_1.8.0.bb')
-rw-r--r--meta-oe/recipes-support/cli11/cli11_1.8.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cli11/cli11_1.8.0.bb b/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
new file mode 100644
index 0000000000..b6a4341595
--- /dev/null
+++ b/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "C++11 command line parser"
+DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface."
+HOMEPAGE = "https://github.com/CLIUtils/CLI11"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b73927b18d5c6cd8d2ed28a6ad539733"
+SRCREV = "13becaddb657eacd090537719a669d66d393b8b2"
+PV .= "+git${SRCPV}"
+
+SRC_URI += "gitsm://github.com/CLIUtils/CLI11 \
+ file://0001-Add-CLANG_TIDY-check.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+inherit ptest
+
+EXTRA_OECMAKE += "-DCLANG_TIDY=OFF"
+DEPENDS += "boost"