aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2018-09-26 23:13:34 +0300
committerKhem Raj <raj.khem@gmail.com>2018-11-26 09:38:13 -0800
commit59577cb5bd7ba4274b311b1c21fdbd80dd125798 (patch)
tree4d168d821f7f36c4f6550068c9828d9b7b3da2fa /meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb
parent79bb01985260800f80b393e73b387543f86f9e62 (diff)
downloadmeta-openembedded-contrib-59577cb5bd7ba4274b311b1c21fdbd80dd125798.tar.gz
bdwgc: upgrade 7.6.0 -> 7.6.8
Highlights of this upgrade: * Fix numerous bugs (concurrency, overflow, CVE-2016-9427, etc.) * Fix various typos in comments and documentation * AddressSanitizer and MemorySanitizer support * RISC-V support See the following for detailed changes: * https://github.com/ivmai/bdwgc/releases/tag/v7.6.2 * https://github.com/ivmai/bdwgc/releases/tag/v7.6.4 * https://github.com/ivmai/bdwgc/releases/tag/v7.6.6 * https://github.com/ivmai/bdwgc/releases/tag/v7.6.8 Signed-off-by: Ivan Maidanski <ivmai@mail.ru> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb')
-rw-r--r--meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb b/meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb
new file mode 100644
index 0000000000..bb78971381
--- /dev/null
+++ b/meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb
@@ -0,0 +1,40 @@
+SUMMARY = "A garbage collector for C and C++"
+
+DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
+ used as a garbage collecting replacement for C malloc or C++ new. It allows\
+ you to allocate memory basically as you normally would, without explicitly\
+ deallocating memory that is no longer useful. The collector automatically\
+ recycles memory when it determines that it can no longer be otherwise\
+ accessed.\
+ The collector is also used by a number of programming language\
+ implementations that either use C as intermediate code, want to facilitate\
+ easier interoperation with C libraries, or just prefer the simple collector\
+ interface.\
+ Alternatively, the garbage collector may be used as a leak detector for C\
+ or C++ programs, though that is not its primary goal.\
+ Empirically, this collector works with most unmodified C programs, simply\
+ by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
+ calls, and removing free calls."
+
+HOMEPAGE = "http://www.hboehm.info/gc/"
+SECTION = "devel"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.QUICK;md5=728501f233050290314d33fb07d883eb"
+
+SRCREV = "8b2a98209a59c92e1be318e4acda507d83175f4d"
+SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-7_6 \
+ "
+
+FILES_${PN}-doc = "${datadir}"
+
+S = "${WORKDIR}/git"
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit autotools pkgconfig
+
+# by default use external libatomic-ops
+PACKAGECONFIG ??= "libatomic-ops"
+PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
+
+BBCLASSEXTEND = "native nativesdk"