aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/bdwgc/bdwgc_7.6.10.bb
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2018-12-15 00:15:06 +0300
committerKhem Raj <raj.khem@gmail.com>2018-12-18 22:15:59 -0800
commit2dc1b2411c7e43475416e79959c1344797516158 (patch)
treecd68e7b4224da8ed87530be7dada788d19fa641b /meta-oe/recipes-support/bdwgc/bdwgc_7.6.10.bb
parentaf94fa02ca443e2dc9338f5fd2c4d62ee99031b3 (diff)
downloadmeta-openembedded-contrib-2dc1b2411c7e43475416e79959c1344797516158.tar.gz
bdwgc: upgrade 7.6.8 -> 7.6.10
Highlights of this upgrade: * Fix races, deadlocks, bugs in disclaim finalization and find-leak mode See the following for detailed changes: * https://github.com/ivmai/bdwgc/releases/tag/v7.6.10 Signed-off-by: Ivan Maidanski <ivmai@mail.ru> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/bdwgc/bdwgc_7.6.10.bb')
-rw-r--r--meta-oe/recipes-support/bdwgc/bdwgc_7.6.10.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bdwgc/bdwgc_7.6.10.bb b/meta-oe/recipes-support/bdwgc/bdwgc_7.6.10.bb
new file mode 100644
index 0000000000..fdf3d6c16d
--- /dev/null
+++ b/meta-oe/recipes-support/bdwgc/bdwgc_7.6.10.bb
@@ -0,0 +1,40 @@
+SUMMARY = "A garbage collector for C and C++"
+
+DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
+ used as a garbage collecting replacement for C malloc or C++ new. It allows\
+ you to allocate memory basically as you normally would, without explicitly\
+ deallocating memory that is no longer useful. The collector automatically\
+ recycles memory when it determines that it can no longer be otherwise\
+ accessed.\
+ The collector is also used by a number of programming language\
+ implementations that either use C as intermediate code, want to facilitate\
+ easier interoperation with C libraries, or just prefer the simple collector\
+ interface.\
+ Alternatively, the garbage collector may be used as a leak detector for C\
+ or C++ programs, though that is not its primary goal.\
+ Empirically, this collector works with most unmodified C programs, simply\
+ by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
+ calls, and removing free calls."
+
+HOMEPAGE = "http://www.hboehm.info/gc/"
+SECTION = "devel"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.QUICK;md5=728501f233050290314d33fb07d883eb"
+
+SRCREV = "cef9cbed83f2b5101d4e65ca0f158600d26cbd34"
+SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-7_6 \
+ "
+
+FILES_${PN}-doc = "${datadir}"
+
+S = "${WORKDIR}/git"
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit autotools pkgconfig
+
+# by default use external libatomic-ops
+PACKAGECONFIG ??= "libatomic-ops"
+PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
+
+BBCLASSEXTEND = "native nativesdk"