aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/atop
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2019-02-12 22:25:12 +0100
committerKhem Raj <raj.khem@gmail.com>2019-02-12 15:47:12 -0800
commitf372c8a480ca40b5dfef41eb0b38f83938e66eb1 (patch)
tree8fee16f672b5426bde3dfd2fb68b24f6f5af82fe /meta-oe/recipes-support/atop
parentc0a71bc2631988dbf7ed72ddf30c67440713ee47 (diff)
downloadmeta-openembedded-contrib-f372c8a480ca40b5dfef41eb0b38f83938e66eb1.tar.gz
atop: Update to 2.4
* Replace remove-bashisms.patch with 0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch to avoid a bashism in atop.init in addition to those already fixed. * Remove 0001-add-sys-sysmacros.h-for-major-minor-macros.patch as it is no longer needed. * Update the remaining patches to avoid fuzz. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/atop')
-rw-r--r--meta-oe/recipes-support/atop/atop/0001-add-sys-sysmacros.h-for-major-minor-macros.patch26
-rw-r--r--meta-oe/recipes-support/atop/atop/0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch67
-rw-r--r--meta-oe/recipes-support/atop/atop/fix-permissions.patch29
-rw-r--r--meta-oe/recipes-support/atop/atop/remove-bashisms.patch33
-rw-r--r--meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch11
-rw-r--r--meta-oe/recipes-support/atop/atop_2.4.0.bb (renamed from meta-oe/recipes-support/atop/atop_2.3.0.bb)9
6 files changed, 98 insertions, 77 deletions
diff --git a/meta-oe/recipes-support/atop/atop/0001-add-sys-sysmacros.h-for-major-minor-macros.patch b/meta-oe/recipes-support/atop/atop/0001-add-sys-sysmacros.h-for-major-minor-macros.patch
deleted file mode 100644
index 5646061971..0000000000
--- a/meta-oe/recipes-support/atop/atop/0001-add-sys-sysmacros.h-for-major-minor-macros.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 13f3771655f859d5e0332dd65b9c43f572f6359d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 11 Aug 2018 16:02:06 -0700
-Subject: [PATCH] add sys/sysmacros.h for major/minor macros
-
-photosyst.c:1465:19: error: called object 'major' is not a function or function pointer
- dmp->major = major(statbuf.st_rdev);
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- photosyst.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/photosyst.c b/photosyst.c
-index 38828ec..caed352 100644
---- a/photosyst.c
-+++ b/photosyst.c
-@@ -152,6 +152,7 @@
- static const char rcsid[] = "$Id: photosyst.c,v 1.38 2010/11/19 07:40:40 gerlof Exp $";
-
- #include <sys/types.h>
-+#include <sys/sysmacros.h>
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
diff --git a/meta-oe/recipes-support/atop/atop/0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch b/meta-oe/recipes-support/atop/atop/0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch
new file mode 100644
index 0000000000..facb257be6
--- /dev/null
+++ b/meta-oe/recipes-support/atop/atop/0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch
@@ -0,0 +1,67 @@
+From ffc8ba8d324243a923abe48e9758adecb03d24a4 Mon Sep 17 00:00:00 2001
+From: Peter Kjellerstedt <pkj@axis.com>
+Date: Tue, 12 Feb 2019 21:25:23 +0100
+Subject: [PATCH] atop.daily, atop.init, atop-pm.sh: Avoid using bash
+
+Avoid using bash and bashisms when not necesary. On some systems,
+e.g., embedded products, bash may not be available by default.
+
+Upstream-Status: Submitted [https://github.com/Atoptool/atop/pull/50]
+Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+---
+ atop-pm.sh | 2 +-
+ atop.daily | 4 ++--
+ atop.init | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/atop-pm.sh b/atop-pm.sh
+index 7f41a86..3ff4ab5 100755
+--- a/atop-pm.sh
++++ b/atop-pm.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ case "$1" in
+ pre) /usr/bin/systemctl stop atop
+diff --git a/atop.daily b/atop.daily
+index 57a9507..fe5a11b 100755
+--- a/atop.daily
++++ b/atop.daily
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ LOGOPTS="-R" # default options
+ LOGINTERVAL=600 # default interval in seconds
+@@ -38,7 +38,7 @@ then
+
+ while ps -p `cat "$PIDFILE"` > /dev/null
+ do
+- let CNT+=1
++ CNT=$((CNT + 1))
+
+ if [ $CNT -gt 5 ]
+ then
+diff --git a/atop.init b/atop.init
+index e6e11dc..03c3f02 100755
+--- a/atop.init
++++ b/atop.init
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # atop Startup script for the Atop process logging in background
+ #
+@@ -47,7 +47,7 @@ case "$1" in
+
+ while ps -p `cat $PIDFILE` > /dev/null
+ do
+- let CNT+=1
++ CNT=$((CNT + 1))
+
+ if [ $CNT -gt 5 ]
+ then
+--
+2.12.0
+
diff --git a/meta-oe/recipes-support/atop/atop/fix-permissions.patch b/meta-oe/recipes-support/atop/atop/fix-permissions.patch
index ee74199939..8488b38000 100644
--- a/meta-oe/recipes-support/atop/atop/fix-permissions.patch
+++ b/meta-oe/recipes-support/atop/atop/fix-permissions.patch
@@ -1,15 +1,22 @@
-Update permissions of executable files that remove setuid bit and make everyone
-could read.
+From d9498d10d0e8241749835dbc9fa229465d4fdfd7 Mon Sep 17 00:00:00 2001
+From: Kai Kang <kai.kang@windriver.com>
+Date: Wed, 6 Feb 2019 13:58:04 +0000
+Subject: [PATCH] Fix permissions
-Upstream-Status: Inappropriate [embedded specific]
+Update permissions of executable files that remove setuid bit and make
+everyone could read.
+Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
+ Makefile | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
diff --git a/Makefile b/Makefile
-index a65b9b6..21d9828 100644
+index 3bf5929..1221ee4 100644
--- a/Makefile
+++ b/Makefile
-@@ -66,7 +66,7 @@ systemdinstall: genericinstall
+@@ -72,7 +72,7 @@ systemdinstall: genericinstall
chmod 0644 $(DESTDIR)$(SYSDPATH)/atopacct.service
cp atop.cronsystemd $(DESTDIR)$(CRNPATH)/atop
cp atop-pm.sh $(DESTDIR)$(PMPATHD)
@@ -18,7 +25,7 @@ index a65b9b6..21d9828 100644
#
# only when making on target system:
#
-@@ -91,11 +91,11 @@ sysvinstall: genericinstall
+@@ -97,11 +97,11 @@ sysvinstall: genericinstall
#
if [ -d $(DESTDIR)$(PMPATH1) ]; \
then cp 45atoppm $(DESTDIR)$(PMPATH1); \
@@ -32,7 +39,7 @@ index a65b9b6..21d9828 100644
fi
#
#
-@@ -139,7 +139,7 @@ genericinstall: atop atopacctd
+@@ -145,7 +145,7 @@ genericinstall: atop atopacctd atopconvert
#
cp atop $(DESTDIR)$(BINPATH)/atop
chown root $(DESTDIR)$(BINPATH)/atop
@@ -41,12 +48,12 @@ index a65b9b6..21d9828 100644
ln -sf atop $(DESTDIR)$(BINPATH)/atopsar
cp atopacctd $(DESTDIR)$(SBINPATH)/atopacctd
chown root $(DESTDIR)$(SBINPATH)/atopacctd
-@@ -147,7 +147,7 @@ genericinstall: atop atopacctd
- cp atop $(DESTDIR)$(BINPATH)/atop-$(VERS)
- ln -sf atop-$(VERS) $(DESTDIR)$(BINPATH)/atopsar-$(VERS)
+@@ -159,7 +159,7 @@ genericinstall: atop atopacctd atopconvert
+ chown root $(DESTDIR)$(BINPATH)/atopconvert
+ chmod 0711 $(DESTDIR)$(BINPATH)/atopconvert
cp atop.daily $(DESTDIR)$(SCRPATH)
- chmod 0711 $(DESTDIR)$(SCRPATH)/atop.daily
+ chmod 0755 $(DESTDIR)$(SCRPATH)/atop.daily
cp man/atop.1 $(DESTDIR)$(MAN1PATH)
cp man/atopsar.1 $(DESTDIR)$(MAN1PATH)
- cp man/atoprc.5 $(DESTDIR)$(MAN5PATH)
+ cp man/atopconvert.1 $(DESTDIR)$(MAN1PATH)
diff --git a/meta-oe/recipes-support/atop/atop/remove-bashisms.patch b/meta-oe/recipes-support/atop/atop/remove-bashisms.patch
deleted file mode 100644
index f1fcbfed76..0000000000
--- a/meta-oe/recipes-support/atop/atop/remove-bashisms.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Kai Kang <kai.kang@windriver.com>
----
-diff --git a/atop-pm.sh b/atop-pm.sh
-index 7f41a86..3ff4ab5 100755
---- a/atop-pm.sh
-+++ b/atop-pm.sh
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- case "$1" in
- pre) /usr/bin/systemctl stop atop
-diff --git a/atop.daily b/atop.daily
-index 24d33bd..f29bd94 100755
---- a/atop.daily
-+++ b/atop.daily
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- CURDAY=`date +%Y%m%d`
- LOGPATH=/var/log/atop
-@@ -16,7 +16,7 @@ then
-
- while ps -p `cat $PIDFILE` > /dev/null
- do
-- let CNT+=1
-+ CNT=$((CNT+1))
-
- if [ $CNT -gt 5 ]
- then
diff --git a/meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch b/meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch
index 5994d3e08e..1145a24934 100644
--- a/meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch
+++ b/meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch
@@ -1,11 +1,18 @@
+From bdd068873ed0979027c21773939bdb18046a8756 Mon Sep 17 00:00:00 2001
+From: Kai Kang <kai.kang@windriver.com>
+Date: Wed, 6 Feb 2019 13:58:04 +0000
+Subject: [PATCH] sysvinit: Implement status
+
Implement the sub-command status.
Upstream-Status: Pending
-
Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
+ atop.init | 3 +++
+ 1 file changed, 3 insertions(+)
+
diff --git a/atop.init b/atop.init
-index 108bdc5..9f89fad 100755
+index e6e11dc..e7b226d 100755
--- a/atop.init
+++ b/atop.init
@@ -18,6 +18,8 @@
diff --git a/meta-oe/recipes-support/atop/atop_2.3.0.bb b/meta-oe/recipes-support/atop/atop_2.4.0.bb
index 302813c2ea..5bde965196 100644
--- a/meta-oe/recipes-support/atop/atop_2.3.0.bb
+++ b/meta-oe/recipes-support/atop/atop_2.4.0.bb
@@ -17,13 +17,12 @@ DEPENDS = "ncurses zlib"
SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \
- file://remove-bashisms.patch \
file://fix-permissions.patch \
file://sysvinit-implement-status.patch \
- file://0001-add-sys-sysmacros.h-for-major-minor-macros.patch \
+ file://0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch \
"
-SRC_URI[md5sum] = "48e1dbef8c7d826e68829a8d5fc920fc"
-SRC_URI[sha256sum] = "73e4725de0bafac8c63b032e8479e2305e3962afbe977ec1abd45f9e104eb264"
+SRC_URI[md5sum] = "1077da884ed94f2bc3c81ac3ab970436"
+SRC_URI[sha256sum] = "be1c010a77086b7d98376fce96514afcd73c3f20a8d1fe01520899ff69a73d69"
do_compile() {
oe_runmake all
@@ -49,7 +48,7 @@ do_install() {
inherit systemd
-SYSTEMD_SERVICE_${PN} = "atop.service"
+SYSTEMD_SERVICE_${PN} = "atop.service atopgpu.service"
SYSTEMD_AUTO_ENABLE = "disable"
FILES_${PN} += "${systemd_unitdir}/system-sleep"