aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/apcupsd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:37:00 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-04 09:06:22 +0100
commitdf7242fddb9048738c0cdfaf0c3c227bf78f3da7 (patch)
tree93d90103179618fe595aa26a7bfab1a0afd55418 /meta-oe/recipes-support/apcupsd
parent7396fc62068a41d2ad88cc03d0ca485279510d55 (diff)
downloadmeta-openembedded-contrib-df7242fddb9048738c0cdfaf0c3c227bf78f3da7.tar.gz
recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode,links"
* Using "cp -a" leaks UID of user running the builds, causing many QA warnings. * See this thread for details: http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/apcupsd')
-rw-r--r--meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
index 18979d574b..35c891e7a7 100644
--- a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
+++ b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
@@ -19,10 +19,10 @@ EXTRA_OECONF = "--without-x \
do_configure() {
export topdir=${S}
- cp -a ${S}/autoconf/configure.in ${S}
+ cp -R --no-dereference --preserve=mode,links -v ${S}/autoconf/configure.in ${S}
if ! [ -d ${S}/platforms/${DISTRO} ] ; then
- cp -a ${S}/platforms/unknown ${S}/platforms/${DISTRO}
+ cp -R --no-dereference --preserve=mode,links -v ${S}/platforms/unknown ${S}/platforms/${DISTRO}
fi
gnu-configize --force