aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/anthy/anthy_9100h.bb
diff options
context:
space:
mode:
authorBian Naimeng <biannm@cn.fujitsu.com>2015-06-26 12:55:52 +0900
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-16 21:09:06 +0200
commit7d15cb6cbdd9d3ef20981c594ed160f1d5b42f3a (patch)
treebfecf821dffeb5fd42bbb05eb1a4ac9b1f3a1601 /meta-oe/recipes-support/anthy/anthy_9100h.bb
parente6d0b7b4432ff10dc3227235e22e9a709aa90cb2 (diff)
downloadmeta-openembedded-contrib-7d15cb6cbdd9d3ef20981c594ed160f1d5b42f3a.tar.gz
anthy: add new recipe
Anthy is a system for Japanese input method. Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
Diffstat (limited to 'meta-oe/recipes-support/anthy/anthy_9100h.bb')
-rw-r--r--meta-oe/recipes-support/anthy/anthy_9100h.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/anthy/anthy_9100h.bb b/meta-oe/recipes-support/anthy/anthy_9100h.bb
new file mode 100644
index 0000000000..e121b447d3
--- /dev/null
+++ b/meta-oe/recipes-support/anthy/anthy_9100h.bb
@@ -0,0 +1,42 @@
+DESCRIPTION="Anthy is a system for Japanese input method. It converts Hiragana text to Kana Kanji mixed text."
+AUTHOR = "Anthy Developers <anthy-dev@lists.sourceforge.jp>"
+HOMEPAGE = "http://anthy.sourceforge.jp"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=11f384074d8e93e263b5664ef08a411a"
+
+SRC_URI = "http://osdn.dl.sourceforge.jp/anthy/37536/anthy-9100h.tar.gz \
+ file://not_build_elc.patch \
+ file://2ch_t.patch \
+ "
+
+SRC_URI_append_class-target = "file://target-helpers.patch"
+SRC_URI_append_class-native = "file://native-helpers.patch"
+
+SRC_URI[md5sum] = "1f558ff7ed296787b55bb1c6cf131108"
+SRC_URI[sha256sum] = "d256f075f018b4a3cb0d165ed6151fda4ba7db1621727e0eb54569b6e2275547"
+
+DEPENDS_class-target = "anthy-native"
+RDEPENDS_${PN}_class-target = "libanthy0"
+
+inherit autotools pkgconfig
+
+PACKAGES += "${PN}-el libanthy0 libanthy-dev"
+
+FILES_${PN}-dbg += "${libdir}/.debug"
+FILES_libanthy0 = "${libdir}/libanthy.so.* \
+ ${libdir}/libanthydic.so.* \
+ ${libdir}/libanthyinput.so.*"
+
+FILES_libanthy-dev = "${libdir}/libanthy*.la \
+ ${libdir}/libanthy*.a \
+ ${libdir}/libanthy*.so \
+ ${includedir}/anthy \
+ ${libdir}/pkgconfig/anthy.pc"
+
+FILES_${PN}-el = "${datadir}/emacs/*"
+FILES_${PN} = "${datadir}/* \
+ ${bindir}/* \
+ ${sysconfdir}/anthy-conf"
+
+BBCLASSEXTEND = "native"