aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-shells
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-05-24 19:59:48 +0200
committerKhem Raj <raj.khem@gmail.com>2021-05-28 06:55:33 -0700
commitb25ea9cb97a7afbffdf4ed01c195ab602213ed18 (patch)
treed597a449409947ea63b9949582e0257712e67ed8 /meta-oe/recipes-shells
parentb3742bef0643600b39a1f8214d8fe3ac7d4e70f7 (diff)
downloadmeta-openembedded-contrib-b25ea9cb97a7afbffdf4ed01c195ab602213ed18.tar.gz
zsh: work around file-rdeps QA issues with usrmerge in DISTRO_FEATURES
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-shells')
-rw-r--r--meta-oe/recipes-shells/zsh/zsh_5.8.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-shells/zsh/zsh_5.8.bb b/meta-oe/recipes-shells/zsh/zsh_5.8.bb
index 6fc5f4d993..f87231db2f 100644
--- a/meta-oe/recipes-shells/zsh/zsh_5.8.bb
+++ b/meta-oe/recipes-shells/zsh/zsh_5.8.bb
@@ -51,3 +51,8 @@ pkg_postinst_${PN} () {
grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells
grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
}
+
+# work around QA failures with usrmerge installing zsh in /usr/bin/zsh instead of /bin/zsh
+# ERROR: QA Issue: /usr/share/zsh/5.8/functions/zed contained in package zsh requires /bin/zsh, but no providers found in RDEPENDS_zsh? [file-rdeps]
+# like bash does since https://git.openembedded.org/openembedded-core/commit/?id=4759408677a4e60c5fa7131afcb5bc184cf2f90a
+RPROVIDES_${PN} += "${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/zsh', '', d)}"