aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-shells/tcsh/tcsh_6.24.11.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-19 13:45:36 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-20 09:28:11 -0700
commit6c1b04a5826d1a939829c4f320f698c176e2b795 (patch)
tree94d57c3715aa1401cfba9eb361fe6ac4bfe16d72 /meta-oe/recipes-shells/tcsh/tcsh_6.24.11.bb
parent291a582faa979498efa74f345bb79bad1838559d (diff)
downloadmeta-openembedded-contrib-6c1b04a5826d1a939829c4f320f698c176e2b795.tar.gz
tcsh: upgrade 6.24.10 -> 6.24.11
Changelog: Make nice priority incremental even with setpriority(2) to match how it worked with nice(3) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-shells/tcsh/tcsh_6.24.11.bb')
-rw-r--r--meta-oe/recipes-shells/tcsh/tcsh_6.24.11.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-shells/tcsh/tcsh_6.24.11.bb b/meta-oe/recipes-shells/tcsh/tcsh_6.24.11.bb
new file mode 100644
index 0000000000..d04ba1611d
--- /dev/null
+++ b/meta-oe/recipes-shells/tcsh/tcsh_6.24.11.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \
+ The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \
+ It includes all features of 4.4BSD C shell, plus a command-line editor, \
+ programmable word completion, spelling correction and more."
+
+HOMEPAGE = "http://www.tcsh.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://Copyright;md5=575cf2715c3bf894e1f79aec1d4eaaf5"
+SECTION = "base"
+DEPENDS = "ncurses virtual/crypt gettext-native"
+SRC_URI = " \
+ https://astron.com/pub/${BPN}/${BP}.tar.gz \
+ file://0001-Enable-system-malloc-on-all-linux.patch \
+ file://0002-Add-debian-csh-scripts.patch \
+"
+SRC_URI[sha256sum] = "b5a7b627abb3ef2e8d3a869bb675d0e927d850704447a1b2c77946c0d324799d"
+
+EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'"
+inherit autotools
+
+do_compile:prepend() {
+ oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' LDFLAGS='${BUILD_LDFLAGS}' gethost
+}
+
+do_install:append () {
+ oe_runmake install.man DESTDIR=${D}
+
+ install -d ${D}${base_bindir}
+ if ! ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
+ ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh
+ ln -s /usr/bin/tcsh ${D}${base_bindir}/csh
+ fi
+ install -d ${D}${sysconfdir}/csh/login.d
+ install -m 0644 ${S}/csh.cshrc ${S}/csh.login ${S}/csh.logout ${S}/complete.tcsh ${D}${sysconfdir}
+ install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el
+}
+
+FILES:${PN} += "${datadir}/emacs/site-lisp/csh-mode.el"
+
+
+pkg_postinst:${PN} () {
+#!/bin/sh -e
+echo /usr/bin/tcsh >> $D/etc/shells
+echo /usr/bin/csh >> $D/etc/shells
+}
+BBCLASSEXTEND = "native nativesdk"