aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-shells/dash/dash_0.5.11.5.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-09-10 05:56:16 +0800
committerArmin Kuster <akuster808@gmail.com>2021-09-26 16:26:19 -0700
commit135af4f1f7e8ef4585756f638b2cbec99943bbb3 (patch)
tree249110f08ab3a483d5f94bc3d2ea3534d3d7d2b1 /meta-oe/recipes-shells/dash/dash_0.5.11.5.bb
parent929c2eebfa78443b53bffc929bb4e47b65824479 (diff)
downloadmeta-openembedded-contrib-135af4f1f7e8ef4585756f638b2cbec99943bbb3.tar.gz
dash: upgrade 0.5.11.3 -> 0.5.11.5
parser: Fix VSLENGTH parsing with trailing garbage eval: Do not cache value of eflag in evaltree Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 633f2115055dbc529f94eb39487e38ba384f6b83) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-shells/dash/dash_0.5.11.5.bb')
-rw-r--r--meta-oe/recipes-shells/dash/dash_0.5.11.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-shells/dash/dash_0.5.11.5.bb b/meta-oe/recipes-shells/dash/dash_0.5.11.5.bb
new file mode 100644
index 0000000000..c2d01986ec
--- /dev/null
+++ b/meta-oe/recipes-shells/dash/dash_0.5.11.5.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Small and fast POSIX-compliant shell"
+HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/"
+SECTION = "System Environment/Shells"
+
+LICENSE = "BSD & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
+
+inherit autotools update-alternatives
+
+SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz"
+SRC_URI[sha256sum] = "db778110891f7937985f29bf23410fe1c5d669502760f584e54e0e7b29e123bd"
+
+EXTRA_OECONF += "--bindir=${base_bindir}"
+
+ALTERNATIVE_${PN} = "sh"
+ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
+ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
+ALTERNATIVE_PRIORITY = "10"
+
+pkg_postinst_${PN} () {
+ grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
+}
+
+pkg_postrm_${PN} () {
+ printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
+}