aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2021-08-28 15:21:19 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-29 09:10:55 -0700
commit584852c8dea20ce3082229ee8ce9a90287c6725f (patch)
tree6913a7339d2529d8f89726e9c44584642370b1fb /meta-oe/recipes-navigation
parent88783990b91e50a3bb8a5174b5e6c793f92f3b6a (diff)
downloadmeta-openembedded-contrib-584852c8dea20ce3082229ee8ce9a90287c6725f.tar.gz
gpsd: Correct the installation of gpsd.hotplug if systemd is not enabled
Reported-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd/0001-SConscript-Correct-the-installation-of-gpsd.hotplug.patch29
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.23.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd/0001-SConscript-Correct-the-installation-of-gpsd.hotplug.patch b/meta-oe/recipes-navigation/gpsd/gpsd/0001-SConscript-Correct-the-installation-of-gpsd.hotplug.patch
new file mode 100644
index 0000000000..172f47825f
--- /dev/null
+++ b/meta-oe/recipes-navigation/gpsd/gpsd/0001-SConscript-Correct-the-installation-of-gpsd.hotplug.patch
@@ -0,0 +1,29 @@
+From c7183b2cc4a42f6ca7c2dc687ee7881efe9aeb73 Mon Sep 17 00:00:00 2001
+From: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+Date: Sat, 28 Aug 2021 14:22:02 +0200
+Subject: [PATCH] SConscript: Correct the installation of gpsd.hotplug
+
+Without this, `scons systemd=false && scons udev-install` fails with:
+
+ cp .../gpsd/gpsd-3.23.1~dev/gpsd.hotplug /home/pkj/gpsd/foobar/lib/udev
+ cp: cannot stat '.../gpsd/gpsd-3.23.1~dev/gpsd.hotplug': No such file or directory
+
+Upstream-Status: Submitted [https://gitlab.com/gpsd/gpsd/-/merge_requests/277]
+Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
+---
+ SConscript | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/SConscript b/SConscript
+index 1cd3354e1..e578012f5 100644
+--- a/SConscript
++++ b/SConscript
+@@ -3060,7 +3060,7 @@ if env['systemd']:
+ hotplug_wrapper_install = []
+ else:
+ hotplug_wrapper_install = [
+- 'cp $SRCDIR/gpsd.hotplug ' + DESTDIR + env['udevdir'],
++ 'cp $SRCDIR/../gpsd.hotplug ' + DESTDIR + env['udevdir'],
+ 'chmod a+x ' + DESTDIR + env['udevdir'] + '/gpsd.hotplug'
+ ]
+
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.23.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.23.bb
index bf5e0efed5..98f0e67a85 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.23.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.23.bb
@@ -6,6 +6,7 @@ DEPENDS = "dbus ncurses python3 pps-tools"
PROVIDES = "virtual/gpsd"
SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
+ file://0001-SConscript-Correct-the-installation-of-gpsd.hotplug.patch \
file://gpsd.init \
"
SRC_URI[md5sum] = "b4f96cb01cbc06542b1cb66b3296078d"