aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorFelipe F. Tonello <eu@felipetonello.com>2013-09-19 19:09:13 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-10-05 12:36:02 +0200
commitf480becafec5315192f6671601f973e41bf2d4ae (patch)
treef53c64295540ce3eb10322843a9ce66d9cf87878 /meta-oe/recipes-navigation
parent653c667a56a2134a883fadc64fccb8a7a6b8bd8e (diff)
downloadmeta-openembedded-contrib-f480becafec5315192f6671601f973e41bf2d4ae.tar.gz
gypsy: Improvements in recipes
Some improvements were made: * Fix recipes to use .inc file * Fix git recipe that was not passing do_configure step * Separeted gypsy daemon from libgypsy in different packages Signed-off-by: Felipe F. Tonello <eu@felipetonello.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gypsy/gypsy.inc16
-rw-r--r--meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb21
-rw-r--r--meta-oe/recipes-navigation/gypsy/gypsy_git.bb12
3 files changed, 26 insertions, 23 deletions
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy.inc b/meta-oe/recipes-navigation/gypsy/gypsy.inc
index ba543568d5..747b61d23b 100644
--- a/meta-oe/recipes-navigation/gypsy/gypsy.inc
+++ b/meta-oe/recipes-navigation/gypsy/gypsy.inc
@@ -5,11 +5,21 @@ concurrently. Gypsy also hides the details of parsing NMEA from the \
client applications, passing the data as simple values for the clients \
to use."
LICENSE = "GPLv2.0 & LGPLv2.1"
-SECTION = "x11"
-DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt-native"
+SECTION = "console/network"
+DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt-native libxslt"
inherit autotools pkgconfig gtk-doc
+PACKAGES += "libgypsy"
EXTRA_OECONF += "--with-distro=debian"
-FILES_${PN} += "/usr/share/dbus-1/services/"
+FILES_${PN} = " \
+ ${sysconfdir}/gypsy.conf \
+ ${sysconfdir}/dbus-1 \
+ ${libexecdir}/gypsy-daemon \
+ ${datadir}/dbus-1 \
+"
+
+FILES_libgypsy = " \
+ ${libdir}/libgypsy${SOLIBS} \
+"
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb b/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb
index 564d3d96f6..24c8987ef9 100644
--- a/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb
+++ b/meta-oe/recipes-navigation/gypsy/gypsy_0.9.bb
@@ -1,26 +1,15 @@
-SUMMARY = "GPS Multiplexing Daemon"
-DESCRIPTION = "Gypsy is a GPS multiplexing daemon which allows \
-multiple clients to access GPS data from multiple GPS sources \
-concurrently. Gypsy also hides the details of parsing NMEA from the \
-client applications, passing the data as simple values for the clients \
-to use."
-LICENSE = "GPLv2+ & LGPLv2+"
+require gypsy.inc
+
+PR = "r2"
+
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \
file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \
file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd"
-SECTION = "x11"
-DEPENDS = "glib-2.0 dbus bluez4 dbus-glib libxslt"
-
-SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \
+SRC_URI += "http://gypsy.freedesktop.org/releases/gypsy-${PV}.tar.gz \
file://0001-g_type_init-is-deprecated-for-glib-2.35.0.patch \
"
-PR = "r1"
-
-inherit autotools pkgconfig
-
-FILES_${PN} += "/usr/share/dbus-1/system-services/"
SRC_URI[md5sum] = "e2d186df9c2cc3b70a027043e22acf1a"
SRC_URI[sha256sum] = "14e1cbe17351f408538e033ca370b4bf51ccf9c88744e236ddfb271904f154d6"
diff --git a/meta-oe/recipes-navigation/gypsy/gypsy_git.bb b/meta-oe/recipes-navigation/gypsy/gypsy_git.bb
index 5431c682b6..6ab16e6bee 100644
--- a/meta-oe/recipes-navigation/gypsy/gypsy_git.bb
+++ b/meta-oe/recipes-navigation/gypsy/gypsy_git.bb
@@ -4,15 +4,19 @@ DEFAULT_PREFERENCE = "-1"
SRCREV = "be8c9c382d2d1d37b51d29b0843045121ec90213"
PV = "0.9+git${SRCPV}"
-PR = "r1"
+PR = "r2"
S = "${WORKDIR}/git"
-LICENSE = "GPLv2+ & LGPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://COPYING.lib;md5=7fbc338309ac38fefcd64b04bb903e34 \
file://src/main.c;beginline=1;endline=25;md5=3fe64e27e61b289b77383a54a982cbdd \
file://gypsy/gypsy-time.h;beginline=1;endline=24;md5=06432ea19a7b6607428d04d9dadc37fd"
-SRC_URI = "git://anongit.freedesktop.org/gypsy \
- file://fixups.patch"
+SRC_URI += "git://anongit.freedesktop.org/gypsy \
+ file://fixups.patch"
+
+do_configure_prepend() {
+ # from patch 563716fc596d53f1085949a9dd11a62f39b2d624
+ test -d ${S}/m4 || mkdir -p ${S}/m4
+}