aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2016-09-07 16:32:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-15 10:22:46 +0200
commitc7137fd871bbc6a2e0c65a3e823d5abdc1feb9e6 (patch)
treeabeef49960d444cc4b04bd561a293b3d6b887c6b /meta-oe/recipes-navigation
parenta231c431a522ae1821fc484bb1a1f9997ecabf20 (diff)
downloadmeta-openembedded-contrib-c7137fd871bbc6a2e0c65a3e823d5abdc1feb9e6.tar.gz
gpsd: make sure the recipe uses LDFLAGS
since commit fa436aeb3242cbfdbbe16d448d45bce8eb5b74fd in OE core, we are seeing GNU_HASH QA failure when building gpsd. Since this commit we default to setting the wrong linker hash style to detect such errors in recipes. gpsd is using scons which does not take LDFLAGS into account, and LDFLAGS need to be passed from the environment, using LINKFLAGS variable. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index 822fc2485e..537facc0e1 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -55,12 +55,14 @@ do_compile_prepend() {
export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
+ export LINKFLAGS="${LDFLAGS}"
}
do_install() {
export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
+ export LINKFLAGS="${LDFLAGS}"
export DESTDIR="${D}"
# prefix is used for RPATH and DESTDIR/prefix for instalation