aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb
diff options
context:
space:
mode:
authorHerman van Hazendonk <github.com@herrie.org>2019-05-23 11:55:03 +0000
committerKhem Raj <raj.khem@gmail.com>2019-05-24 10:11:28 -0700
commitc6afebe0ec82ce0c90194b1edf7f50c014569ea0 (patch)
treeb1c494c70253f36e60813ec4bc66d3c4ae82e0fa /meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb
parentfe16fd1ae23360bf525885c913cb7750b7716ff3 (diff)
downloadmeta-openembedded-contrib-c6afebe0ec82ce0c90194b1edf7f50c014569ea0.tar.gz
Geoclue: Update to 2.5.3
* Switch to Meson build system. * Fix a crash. * Support for GGA messages from more NMEA sources. * New API to allow automatic server side deletion of client. * Automatically delete client on server when using GClueSimple. * Avoid linking to system-installed library. * Fix library-only build. * Add manpage for geoclue.conf file. * Document usage and building of the project. * Other fixes and improvements. Signed-off-by: Herman van Hazendonk <github.com@herrie.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb')
-rw-r--r--meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb b/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb
new file mode 100644
index 0000000000..b46445a2ba
--- /dev/null
+++ b/meta-oe/recipes-navigation/geoclue/geoclue_2.5.3.bb
@@ -0,0 +1,54 @@
+SUMMARY = "The Geolocation Service"
+DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
+The primary goal of the Geoclue project is to make creating location-aware applications \
+as simple as possible, while the secondary goal is to ensure that no application \
+can access location information without explicit permission from user."
+LICENSE = "GPLv2.0+"
+SECTION = "console/network"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6"
+
+DEPENDS = "glib-2.0 dbus json-glib libsoup-2.4 intltool-native"
+
+inherit meson pkgconfig gtk-doc gobject-introspection vala
+
+SRC_URI = " \
+ https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/${PV}/geoclue-${PV}.tar \
+"
+
+SRC_URI[md5sum] = "6228301ed62b587ebaa0438b97ce66e4"
+SRC_URI[sha256sum] = "3caa5e10190a34c17a9b3a9d1d8a19797ed197f07f36f6e35ce533a379efe155"
+
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+# Without this line, package is declared a library and named libgeoclue*
+AUTO_LIBNAME_PKGS = ""
+
+PACKAGECONFIG ??= "3g modem-gps cdma nmea lib"
+PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager"
+PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager"
+PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager"
+PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi"
+PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection"
+
+GTKDOC_MESON_OPTION = "gtk-doc"
+
+EXTRA_OEMESON += " \
+ -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \
+ -Ddemo-agent=false \
+"
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1/system-services \
+ ${libdir} \
+ ${systemd_unitdir} \
+ ${prefix}/libexec \
+"
+
+FILES_${PN}-dev += " \
+ ${datadir}/dbus-1/interfaces \
+ ${datadir}/gir-1.0 \
+"