aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-10-21 21:40:18 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-23 12:57:22 +0200
commit534b72af6935e8050643572d6c72e004f91c25b8 (patch)
treeacf4e43bd2f01828621a0a6e902b2ccb06f39934 /meta-oe/recipes-multimedia
parentc08d76640177968f7736a6d5de1c93e4f863edf0 (diff)
downloadmeta-openembedded-contrib-534b72af6935e8050643572d6c72e004f91c25b8.tar.gz
libsdl2-image: Initial add 2.0.0
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/libsdl-image/libsdl2-image_2.0.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/libsdl-image/libsdl2-image_2.0.0.bb b/meta-oe/recipes-multimedia/libsdl-image/libsdl2-image_2.0.0.bb
new file mode 100644
index 0000000000..a6885da03d
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libsdl-image/libsdl2-image_2.0.0.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Simple DirectMedia Layer image library v2"
+SECTION = "libs"
+
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=8f66a2e45aa301ea73b5ab275aeb0702"
+
+DEPENDS = "tiff zlib libpng jpeg virtual/libsdl2 libwebp"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL2_image-${PV}.tar.gz"
+SRC_URI[md5sum] = "fb399c8386fb3248f1b33cfe81bdf92b"
+SRC_URI[sha256sum] = "b29815c73b17633baca9f07113e8ac476ae66412dec0d29a5045825c27a47234"
+
+S = "${WORKDIR}/SDL2_image-${PV}"
+
+inherit autotools pkgconfig
+
+# Disable the run-time loading of the libs and bring back the soname dependencies.
+EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared"
+
+do_configure_prepend() {
+ # make autoreconf happy
+ touch ${S}/NEWS ${S}/README ${S}/AUTHORS ${S}/ChangeLog
+ # Removing these files fixes a libtool version mismatch.
+ rm -f ${S}/acinclude/libtool.m4
+ rm -f ${S}/acinclude/sdl2.m4
+ rm -f ${S}/acinclude/pkg.m4
+ rm -f ${S}/acinclude/lt~obsolete.m4
+ rm -f ${S}/acinclude/ltoptions.m4
+ rm -f ${S}/acinclude/ltsugar.m4
+ rm -f ${S}/acinclude/ltversion.m4
+}