aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-11-30 12:51:23 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-09 12:02:14 +0100
commit4fc06fd23709e77a5ee05b1f0fde57d410fcaba6 (patch)
treefba7a46a414ecdc29a96c2fca8ab6dcfd82bc6ab /meta-oe/recipes-multimedia
parent9cd05c16510cb0b6a09f72e5c7488d021a55440b (diff)
downloadmeta-openembedded-contrib-4fc06fd23709e77a5ee05b1f0fde57d410fcaba6.tar.gz
libcdio: clean up recipe
Fix description, use packageconfig, use packagesplitfuncs. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/libcdio/libcdio_0.93.bb19
1 files changed, 11 insertions, 8 deletions
diff --git a/meta-oe/recipes-multimedia/libcdio/libcdio_0.93.bb b/meta-oe/recipes-multimedia/libcdio/libcdio_0.93.bb
index f21f91446e..99e6a84bca 100644
--- a/meta-oe/recipes-multimedia/libcdio/libcdio_0.93.bb
+++ b/meta-oe/recipes-multimedia/libcdio/libcdio_0.93.bb
@@ -1,25 +1,28 @@
-ESCRIPTION = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
+SUMMARY = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
HOMEPAGE = "http://www.gnu.org/software/libcdio/"
SECTION = "libs"
-
LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-DEPENDS = "ncurses"
-
SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz"
SRC_URI[md5sum] = "d154476feaac5a7b5f180e83eaf3d689"
SRC_URI[sha256sum] = "4972cd22fd8d0e8bff922d35c7a645be0db0ab0e7b3dfaecc9cd8272429d6975"
inherit autotools pkgconfig
+PACKAGECONFIG ??= "cdda-player"
+PACKAGECONFIG[cdda-player] = "--with-cdda-player,--without-cdda-player,ncurses"
+PACKAGECONFIG[cddb] = "--enable-cddb,--disable-cddb,libcddb"
+PACKAGECONFIG[vcd-info] = "--enable-vcd-info,--disable-vcd-info,vcdimager"
+
PACKAGES += "${PN}-utils"
-FILES_${PN} = "${libdir}/${PN}${SOLIB}"
+FILES_${PN} = "${libdir}/${BPN}${SOLIB}"
FILES_${PN}-utils = "${bindir}/*"
-python populate_packages_prepend () {
- glibdir = d.expand('${libdir}')
- do_split_packages(d, glibdir, '^lib(.*)\.so\..*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True)
+python libcdio_split_packages() {
+ libdir = d.expand('${libdir}')
+ do_split_packages(d, libdir, '^lib(.*)\.so\..*', 'lib%s', 'libcdio %s library', extra_depends='', allow_links=True)
}
+PACKAGESPLITFUNCS =+ "libcdio_split_packages"