aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/webm/libvpx_1.7.0.bb
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2018-12-22 14:09:14 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-22 15:37:36 -0800
commitd8730f4328c32b2674e9ff76cb8f2c663c8a8dad (patch)
tree936df360f661862378ce728d9a892df8bb2a6dc8 /meta-oe/recipes-multimedia/webm/libvpx_1.7.0.bb
parenta96e6d718e98f9fadfd30e8ac850ebfc62ed0363 (diff)
downloadmeta-openembedded-contrib-d8730f4328c32b2674e9ff76cb8f2c663c8a8dad.tar.gz
libvpx: bump to 1.7.0
Fetch was switched from tarball to git fetcher with release tag because libvpx-1.7.0.tar.bz2 was not available at the previous download URL. The download instructions for the project point to autogenerated tarballs now (instead of storage.googleapis.com) [1], but archive tarballs generated by git can end up with checksums that change over time... so using git directly is less likely to break. Successfully compile tested against: * ffmpeg-4.0.2 * gstreamer1.0-plugins-good-1.14.2 * vlc-2.2.2 with vpx enabled in each respective PACKAGECONFIG. [1] https://www.webmproject.org/code/releases/ Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/webm/libvpx_1.7.0.bb')
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx_1.7.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.7.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.7.0.bb
new file mode 100644
index 0000000000..1d04ed1bdb
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webm/libvpx_1.7.0.bb
@@ -0,0 +1,51 @@
+SUMMARY = "VPX multi-format codec"
+DESCRIPTION = "The BSD-licensed libvpx reference implementation provides en- and decoders for VP8 and VP9 bitstreams."
+HOMEPAGE = "http://www.webmproject.org/code/"
+BUGTRACKER = "http://code.google.com/p/webm/issues/list"
+SECTION = "libs/multimedia"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4"
+
+# SRCREV for 1.7.0
+SRCREV = "133f83e2c34b8d770ae06aa595cef3e254173fcb"
+SRC_URI += "git://chromium.googlesource.com/webm/libvpx;protocol=https \
+ file://libvpx-configure-support-blank-prefix.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+# ffmpeg links with this and fails
+# sysroots/armv4t-oe-linux-gnueabi/usr/lib/libvpx.a(vpx_encoder.c.o)(.text+0xc4): unresolvable R_ARM_THM_CALL relocation against symbol `memcpy@@GLIBC_2.4'
+ARM_INSTRUCTION_SET = "arm"
+
+CFLAGS += "-fPIC"
+
+export CC
+export LD = "${CC}"
+
+VPXTARGET_armv5te = "armv5te-linux-gcc"
+VPXTARGET_armv6 = "armv6-linux-gcc"
+VPXTARGET_armv7a = "armv7-linux-gcc"
+VPXTARGET ?= "generic-gnu"
+
+CONFIGUREOPTS = " \
+ --target=${VPXTARGET} \
+ --enable-vp9 \
+ --enable-libs \
+ --disable-install-docs \
+ --disable-static \
+ --enable-shared \
+ --prefix=${prefix} \
+ --libdir=${libdir} \
+ --size-limit=16384x16384 \
+"
+
+do_configure() {
+ ${S}/configure ${CONFIGUREOPTS}
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ chown -R root:root ${D}
+}