aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/mplayer
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-11-09 20:55:12 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-16 08:43:43 +0100
commitc59fda28b29afcdcb245651cabbe08a76856d8ca (patch)
treee6bb6b8fd73a8a2e927a6ba11340dc073946d00c /meta-oe/recipes-multimedia/mplayer
parent06ad2a21f24e908adf3aa6930aa4d06d3e8bd3af (diff)
downloadmeta-openembedded-contrib-c59fda28b29afcdcb245651cabbe08a76856d8ca.tar.gz
mplayer2: drop FULL_OPTIMIZATION_armv7a and add -fno-tree-vectorize
* we had -ftree-vectorize instead of -frename-registers here, but that's causing ICE with latest gcc-4.6 from meta-oe * qemux86-64 was still failing without -fno-tree-vectorize * similar to issue in libvpx http://lists.linuxtogo.org/pipermail/openembedded-devel/2011-November/036001.html and lowering to -O3 is not enough in this case | libmpcodecs/ad_imaadpcm.c: In function 'qt_ima_adpcm_decode_block': | libmpcodecs/ad_imaadpcm.c:177:12: internal compiler error: Segmentation fault | Please submit a full bug report, | with preprocessed source if appropriate. | See <http://gcc.gnu.org/bugs.html> for instructions. | make: *** [libmpcodecs/ad_imaadpcm.o] Error 1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/mplayer')
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
index ee64ca80d2..72d5754991 100644
--- a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
+++ b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
@@ -21,7 +21,7 @@ SRCREV = "e3f5043233336d8b4b0731c6a8b42a8fda5535ac"
ARM_INSTRUCTION_SET = "ARM"
PV = "2.0+gitr${SRCPV}"
-PR = "r3"
+PR = "r4"
PARALLEL_MAKE = ""
@@ -130,8 +130,7 @@ EXTRA_OECONF = " \
EXTRA_OECONF_append_armv6 = " --enable-armv6"
EXTRA_OECONF_append_armv7a = " --enable-armv6 --enable-neon"
-FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O4 -ffast-math"
-FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -ftree-vectorize -fomit-frame-pointer -O4 -ffast-math"
+FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O4 -ffast-math -fno-tree-vectorize"
BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
CFLAGS_append = " -I${S}/libdvdread4 "