aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/mplayer
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-11-30 08:06:48 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-01 09:19:20 +0100
commit33cf69deda88c0b5c0090f81f4d641366000bc64 (patch)
tree044b709f03585b4b6504afd0627e9bd2e2e84e91 /meta-oe/recipes-multimedia/mplayer
parent80e3a0c42db89fa2716b0a839b8ef71d6d6349db (diff)
downloadmeta-openembedded-contrib-33cf69deda88c0b5c0090f81f4d641366000bc64.tar.gz
mplayer-common: import from OE-classic
* default ao is now alsa instead of oss * ffmp3float is terribly slow on armv4t without FPU, mad is better * commit b28081b6039db85f18bf9e722fece59bff6e7b0f Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/mplayer')
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mplayer-common.bb22
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mplayer-common/mplayer.conf15
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mplayer-common.bb b/meta-oe/recipes-multimedia/mplayer/mplayer-common.bb
new file mode 100644
index 0000000000..889bb95227
--- /dev/null
+++ b/meta-oe/recipes-multimedia/mplayer/mplayer-common.bb
@@ -0,0 +1,22 @@
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: MIT (see COPYING.MIT)
+
+DESCRIPTION = "Preconfigured mplayer preferences"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PV = "0.0.1"
+
+SRC_URI = "file://mplayer.conf"
+
+# Yes, really /usr/etc!!!
+do_install() {
+ install -d "${D}/usr${sysconfdir}/mplayer"
+
+ install -m 0644 ${WORKDIR}/mplayer.conf "${D}/usr${sysconfdir}/mplayer"
+}
+
+FILES_${PN} = "/usr${sysconfdir}/mplayer"
+
+inherit allarch
diff --git a/meta-oe/recipes-multimedia/mplayer/mplayer-common/mplayer.conf b/meta-oe/recipes-multimedia/mplayer/mplayer-common/mplayer.conf
new file mode 100644
index 0000000000..37ad65fa2d
--- /dev/null
+++ b/meta-oe/recipes-multimedia/mplayer/mplayer-common/mplayer.conf
@@ -0,0 +1,15 @@
+
+# You probably shouldn't touch these
+ac=mad,
+ao=alsa,
+
+# Required on SL-Cxxxx for correct rotation in the *VT*,
+# breaks rotation in X!
+# vf=rotate=1
+
+# Enable fullscreen display by default
+# fs=true
+
+# Drop frames to keep audio and video in sync
+framedrop=true
+