aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/live555/live555.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-multimedia/live555/live555.inc
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/live555/live555.inc')
-rw-r--r--meta-oe/recipes-multimedia/live555/live555.inc48
1 files changed, 24 insertions, 24 deletions
diff --git a/meta-oe/recipes-multimedia/live555/live555.inc b/meta-oe/recipes-multimedia/live555/live555.inc
index 443f818182..966224d7f5 100644
--- a/meta-oe/recipes-multimedia/live555/live555.inc
+++ b/meta-oe/recipes-multimedia/live555/live555.inc
@@ -19,36 +19,36 @@ S = "${WORKDIR}/live"
TARGET_CC_ARCH += "${LDFLAGS}"
do_configure() {
- cp ${WORKDIR}/config.linux-cross .
- echo "COMPILE_OPTS+=" -fPIC "" >> config.linux-cross
- ./genMakefiles linux-cross
+ cp ${WORKDIR}/config.linux-cross .
+ echo "COMPILE_OPTS+=" -fPIC "" >> config.linux-cross
+ ./genMakefiles linux-cross
}
do_compile() {
- make
+ make
}
do_install() {
- install -d ${D}${includedir}/BasicUsageEnvironment
- install -d ${D}${includedir}/groupsock
- install -d ${D}${includedir}/liveMedia
- install -d ${D}${includedir}/UsageEnvironment
- install -d ${D}${libdir}
- cp -a ${S}/BasicUsageEnvironment/include/*.hh ${D}${includedir}/BasicUsageEnvironment/
- cp -a ${S}/groupsock/include/*.h ${D}${includedir}/groupsock/
- cp -a ${S}/groupsock/include/*.hh ${D}${includedir}/groupsock/
- cp -a ${S}/liveMedia/include/*.hh ${D}${includedir}/liveMedia/
- cp -a ${S}/UsageEnvironment/include/*.hh ${D}${includedir}/UsageEnvironment/
- # Find all the headers
- for i in $(find . -name "*.hh") $(find . -name "*.h") ; do
- install ${i} ${D}${includedir}
- done
- cp ${S}/*/*.a ${D}${libdir}
- install -d ${D}${bindir}
- for i in MPEG2TransportStreamIndexer openRTSP playSIP sapWatch testMPEG1or2AudioVideoToDarwin testMPEG1or2ProgramToTransportStream testMPEG1or2Splitter testMPEG1or2VideoReceiver testMPEG2TransportStreamTrickPlay testMPEG4VideoToDarwin testOnDemandRTSPServer testRelay testAMRAudioStreamer testDVVideoStreamer testMP3Receiver testMP3Streamer testMPEG1or2AudioVideoStreamer testMPEG1or2VideoStreamer testMPEG2TransportStreamer testMPEG4VideoStreamer testWAVAudioStreamer vobStreamer; do
- install -m 0755 ${S}/testProgs/${i} ${D}${bindir}/
- done
- install -m 0755 ${S}/mediaServer/live555MediaServer ${D}${bindir}/
+ install -d ${D}${includedir}/BasicUsageEnvironment
+ install -d ${D}${includedir}/groupsock
+ install -d ${D}${includedir}/liveMedia
+ install -d ${D}${includedir}/UsageEnvironment
+ install -d ${D}${libdir}
+ cp -a ${S}/BasicUsageEnvironment/include/*.hh ${D}${includedir}/BasicUsageEnvironment/
+ cp -a ${S}/groupsock/include/*.h ${D}${includedir}/groupsock/
+ cp -a ${S}/groupsock/include/*.hh ${D}${includedir}/groupsock/
+ cp -a ${S}/liveMedia/include/*.hh ${D}${includedir}/liveMedia/
+ cp -a ${S}/UsageEnvironment/include/*.hh ${D}${includedir}/UsageEnvironment/
+ # Find all the headers
+ for i in $(find . -name "*.hh") $(find . -name "*.h") ; do
+ install ${i} ${D}${includedir}
+ done
+ cp ${S}/*/*.a ${D}${libdir}
+ install -d ${D}${bindir}
+ for i in MPEG2TransportStreamIndexer openRTSP playSIP sapWatch testMPEG1or2AudioVideoToDarwin testMPEG1or2ProgramToTransportStream testMPEG1or2Splitter testMPEG1or2VideoReceiver testMPEG2TransportStreamTrickPlay testMPEG4VideoToDarwin testOnDemandRTSPServer testRelay testAMRAudioStreamer testDVVideoStreamer testMP3Receiver testMP3Streamer testMPEG1or2AudioVideoStreamer testMPEG1or2VideoStreamer testMPEG2TransportStreamer testMPEG4VideoStreamer testWAVAudioStreamer vobStreamer; do
+ install -m 0755 ${S}/testProgs/${i} ${D}${bindir}/
+ done
+ install -m 0755 ${S}/mediaServer/live555MediaServer ${D}${bindir}/
}
PACKAGES =+ " live555-openrtsp live555-playsip live555-mediaserver"