aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/libsdl-image
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-12-16 15:29:05 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-16 15:29:05 +0100
commit54cee9bcec87775dc436a11e4caacc72084df52b (patch)
tree64bb74bdc69d128e3841a27b117d67645ce98095 /meta-oe/recipes-multimedia/libsdl-image
parent8b445cca7de4c6b34004198d8d4ec1bb7c9c20c0 (diff)
downloadmeta-openembedded-contrib-54cee9bcec87775dc436a11e4caacc72084df52b.tar.gz
libsdl-image: add 1.2.10
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/libsdl-image')
-rw-r--r--meta-oe/recipes-multimedia/libsdl-image/libsdl-image_1.2.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/libsdl-image/libsdl-image_1.2.10.bb b/meta-oe/recipes-multimedia/libsdl-image/libsdl-image_1.2.10.bb
new file mode 100644
index 0000000000..8bc9322f74
--- /dev/null
+++ b/meta-oe/recipes-multimedia/libsdl-image/libsdl-image_1.2.10.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Simple DirectMedia Layer image library."
+SECTION = "libs"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4"
+
+DEPENDS = "tiff zlib libpng jpeg virtual/libsdl"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz"
+SRC_URI[md5sum] = "6c06584b31559e2b59f2b982d0d1f628"
+SRC_URI[sha256sum] = "75e05d1e95f6277b44797157d9e25a908ba8d08a393216ffb019b0d74de11876"
+
+S = "${WORKDIR}/SDL_image-${PV}"
+
+inherit autotools
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+# Disable the run-time loading of the libs and bring back the soname dependencies.
+EXTRA_OECONF += "--disable-jpg-shared --disable-png-shared -disable-tif-shared"
+
+do_configure_prepend() {
+ # Removing this file fixes a libtool version mismatch.
+ rm -f acinclude/libtool.m4
+ rm -f acinclude/sdl.m4
+ rm -f acinclude/pkg.m4
+ rm -f acinclude/lt~obsolete.m4
+ rm -f acinclude/ltoptions.m4
+ rm -f acinclude/ltsugar.m4
+ rm -f acinclude/ltversion.m4
+}
+