aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/libopus
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-25 15:28:52 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:16:17 +0100
commitefd3696e70a6603f1a45faa4a172433514f0a487 (patch)
treeb72751ba93b050391db05a8e1be7506836b6d515 /meta-oe/recipes-multimedia/libopus
parent761639b9d7681c81dd69eaf3a37c32791d6e97fd (diff)
downloadmeta-openembedded-contrib-efd3696e70a6603f1a45faa4a172433514f0a487.tar.gz
remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/libopus')
-rw-r--r--meta-oe/recipes-multimedia/libopus/libopus_1.1.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-multimedia/libopus/libopus_1.1.2.bb b/meta-oe/recipes-multimedia/libopus/libopus_1.1.2.bb
index 9d9a6342e6..e5882e8b9c 100644
--- a/meta-oe/recipes-multimedia/libopus/libopus_1.1.2.bb
+++ b/meta-oe/recipes-multimedia/libopus/libopus_1.1.2.bb
@@ -27,11 +27,11 @@ EXTRA_OECONF = "--with-NE10-includes=${STAGING_DIR_TARGET}${includedir} \
"
python () {
- if d.getVar('TARGET_FPU', True) in [ 'soft' ]:
+ if d.getVar('TARGET_FPU') in [ 'soft' ]:
d.appendVar('PACKAGECONFIG', ' fixed-point')
# Ne10 is only available for armv7 and aarch64
- if any((t.startswith('armv7') or t.startswith('aarch64')) for t in d.getVar('TUNE_FEATURES', True).split()):
+ if any((t.startswith('armv7') or t.startswith('aarch64')) for t in d.getVar('TUNE_FEATURES').split()):
d.appendVar('DEPENDS', ' ne10')
}