aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorMatteo Croce <mcroce@microsoft.com>2021-03-10 03:48:24 +0100
committerKhem Raj <raj.khem@gmail.com>2021-03-11 00:12:55 -0800
commitac05388b628aa2d7bec996438eb786b2cd57f451 (patch)
treed1dcdbb2eb447af8567a1ae4a8d19b2f6579bebc /meta-oe/recipes-kernel
parent3c4e5440074a246c3a84f96416d38be46e0ca227 (diff)
downloadmeta-openembedded-contrib-ac05388b628aa2d7bec996438eb786b2cd57f451.tar.gz
libbpf: use pkg-config
The libbpf makefile uses pkg-config to get the libelf build flags and file paths. Inherit pkgconfig so the install target can copy the binaries in the sysroot, which are needed by other packages, like bcc. Signed-off-by: Matteo Croce <mcroce@microsoft.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/libbpf/libbpf_0.3.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-kernel/libbpf/libbpf_0.3.bb b/meta-oe/recipes-kernel/libbpf/libbpf_0.3.bb
index 5714ddb612..8b548d0b58 100644
--- a/meta-oe/recipes-kernel/libbpf/libbpf_0.3.bb
+++ b/meta-oe/recipes-kernel/libbpf/libbpf_0.3.bb
@@ -23,6 +23,8 @@ S = "${WORKDIR}/git/src"
EXTRA_OEMAKE += "DESTDIR=${D} LIBDIR=${libdir}"
+inherit pkgconfig
+
do_compile() {
if grep -q "CONFIG_BPF_SYSCALL=y" ${STAGING_KERNEL_BUILDDIR}/.config
then
@@ -40,5 +42,3 @@ do_install() {
bbnote "no files to install"
fi
}
-
-BBCLASSEXTEND = "native"