aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-kernel
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc8
-rw-r--r--meta-oe/recipes-kernel/linux/linux.inc182
2 files changed, 95 insertions, 95 deletions
diff --git a/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
index 30d52cc19b..41f673ac84 100644
--- a/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
+++ b/meta-oe/recipes-kernel/compat-wireless/compat-wireless.inc
@@ -10,8 +10,8 @@ COMPAT_WIRELESS_VERSION = "${PV}-1"
SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
SRC_URI = " \
- http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v${SHRT_VER}/compat-wireless-${COMPAT_WIRELESS_VERSION}.tar.bz2 \
- file://0001-ath5k-fix-compilation-without-CONFIG_PCI.patch \
+ http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v${SHRT_VER}/compat-wireless-${COMPAT_WIRELESS_VERSION}.tar.bz2 \
+ file://0001-ath5k-fix-compilation-without-CONFIG_PCI.patch \
"
S = "${WORKDIR}/compat-wireless-${COMPAT_WIRELESS_VERSION}"
@@ -21,9 +21,9 @@ inherit module
EXTRA_OEMAKE = "KLIB_BUILD=${STAGING_KERNEL_DIR} KLIB=${D}"
do_configure_append() {
- sed -i "s#@./scripts/update-initramfs## " Makefile
+ sed -i "s#@./scripts/update-initramfs## " Makefile
}
do_install() {
- oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules
+ oe_runmake DEPMOD=echo DESTDIR="${D}" INSTALL_MOD_PATH="${D}" LDFLAGS="" install-modules
}
diff --git a/meta-oe/recipes-kernel/linux/linux.inc b/meta-oe/recipes-kernel/linux/linux.inc
index 2b2fbf3520..7b301ae211 100644
--- a/meta-oe/recipes-kernel/linux/linux.inc
+++ b/meta-oe/recipes-kernel/linux/linux.inc
@@ -25,106 +25,106 @@ LOCALVERSION ?= ""
#kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\""
kernel_conf_variable() {
- CONF_SED_SCRIPT="$CONF_SED_SCRIPT /CONFIG_$1[ =]/d;"
- if test "$2" = "n"
- then
- echo "# CONFIG_$1 is not set" >> ${S}/.config
- else
- echo "CONFIG_$1=$2" >> ${S}/.config
- fi
+ CONF_SED_SCRIPT="$CONF_SED_SCRIPT /CONFIG_$1[ =]/d;"
+ if test "$2" = "n"
+ then
+ echo "# CONFIG_$1 is not set" >> ${S}/.config
+ else
+ echo "CONFIG_$1=$2" >> ${S}/.config
+ fi
}
do_configure_prepend() {
- echo "" > ${S}/.config
- CONF_SED_SCRIPT=""
-
- #
- # logo support, if you supply logo_linux_clut224.ppm in SRC_URI, then it's going to be used
- #
- if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then
- install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm drivers/video/logo/logo_linux_clut224.ppm
- kernel_conf_variable LOGO y
- kernel_conf_variable LOGO_LINUX_CLUT224 y
- fi
-
- #
- # oabi / eabi support
- #
- kernel_conf_variable AEABI y
- if [ "${ARM_KEEP_OABI}" = "1" ] ; then
- kernel_conf_variable OABI_COMPAT y
- else
- kernel_conf_variable OABI_COMPAT n
- fi
-
- # When enabling thumb for userspace we also need thumb support in the kernel
- if [ "${ARM_INSTRUCTION_SET}" = "thumb" ] ; then
- kernel_conf_variable ARM_THUMB y
- fi
-
- kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\""
-
- kernel_conf_variable LOCALVERSION "\"${LOCALVERSION}\""
- kernel_conf_variable LOCALVERSION_AUTO n
-
- kernel_conf_variable SYSFS_DEPRECATED n
- kernel_conf_variable SYSFS_DEPRECATED_V2 n
- kernel_conf_variable HOTPLUG y
- kernel_conf_variable UEVENT_HELPER_PATH \"\"
- kernel_conf_variable UNIX y
- kernel_conf_variable SYSFS y
- kernel_conf_variable PROC_FS y
- kernel_conf_variable TMPFS y
- kernel_conf_variable INOTIFY_USER y
- kernel_conf_variable SIGNALFD y
- kernel_conf_variable TMPFS_POSIX_ACL y
- kernel_conf_variable BLK_DEV_BSG y
- kernel_conf_variable DEVTMPFS y
- kernel_conf_variable DEVTMPFS_MOUNT y
-
- # Newer inits like systemd need cgroup support
- if [ "${KERNEL_ENABLE_CGROUPS}" = "1" ] ; then
- kernel_conf_variable CGROUP_SCHED y
- kernel_conf_variable CGROUPS y
- kernel_conf_variable CGROUP_NS y
- kernel_conf_variable CGROUP_FREEZER y
- kernel_conf_variable CGROUP_DEVICE y
- kernel_conf_variable CPUSETS y
- kernel_conf_variable PROC_PID_CPUSET y
- kernel_conf_variable CGROUP_CPUACCT y
- kernel_conf_variable RESOURCE_COUNTERS y
- fi
-
- #
- # root-over-nfs-over-usb-eth support. Limited, but should cover some cases.
- # Enable this by setting a proper CMDLINE_NFSROOT_USB.
- #
- if [ ! -z "${CMDLINE_NFSROOT_USB}" ]; then
- bbnote "Configuring the kernel for root-over-nfs-over-usb-eth with CMDLINE ${CMDLINE_NFSROOT_USB}"
- kernel_conf_variable INET y
- kernel_conf_variable IP_PNP y
- kernel_conf_variable USB_GADGET y
- kernel_conf_variable USB_GADGET_SELECTED y
- kernel_conf_variable USB_ETH y
- kernel_conf_variable NFS_FS y
- kernel_conf_variable ROOT_NFS y
- kernel_conf_variable CMDLINE \"${CMDLINE_NFSROOT_USB} ${CMDLINE_DEBUG}\"
- fi
-
- sed -e "${CONF_SED_SCRIPT}" \
- < '${WORKDIR}/defconfig' >>'${S}/.config'
-
- yes '' | oe_runmake oldconfig
+ echo "" > ${S}/.config
+ CONF_SED_SCRIPT=""
+
+ #
+ # logo support, if you supply logo_linux_clut224.ppm in SRC_URI, then it's going to be used
+ #
+ if [ -e ${WORKDIR}/logo_linux_clut224.ppm ]; then
+ install -m 0644 ${WORKDIR}/logo_linux_clut224.ppm drivers/video/logo/logo_linux_clut224.ppm
+ kernel_conf_variable LOGO y
+ kernel_conf_variable LOGO_LINUX_CLUT224 y
+ fi
+
+ #
+ # oabi / eabi support
+ #
+ kernel_conf_variable AEABI y
+ if [ "${ARM_KEEP_OABI}" = "1" ] ; then
+ kernel_conf_variable OABI_COMPAT y
+ else
+ kernel_conf_variable OABI_COMPAT n
+ fi
+
+ # When enabling thumb for userspace we also need thumb support in the kernel
+ if [ "${ARM_INSTRUCTION_SET}" = "thumb" ] ; then
+ kernel_conf_variable ARM_THUMB y
+ fi
+
+ kernel_conf_variable CMDLINE "\"${CMDLINE} ${CMDLINE_DEBUG}\""
+
+ kernel_conf_variable LOCALVERSION "\"${LOCALVERSION}\""
+ kernel_conf_variable LOCALVERSION_AUTO n
+
+ kernel_conf_variable SYSFS_DEPRECATED n
+ kernel_conf_variable SYSFS_DEPRECATED_V2 n
+ kernel_conf_variable HOTPLUG y
+ kernel_conf_variable UEVENT_HELPER_PATH \"\"
+ kernel_conf_variable UNIX y
+ kernel_conf_variable SYSFS y
+ kernel_conf_variable PROC_FS y
+ kernel_conf_variable TMPFS y
+ kernel_conf_variable INOTIFY_USER y
+ kernel_conf_variable SIGNALFD y
+ kernel_conf_variable TMPFS_POSIX_ACL y
+ kernel_conf_variable BLK_DEV_BSG y
+ kernel_conf_variable DEVTMPFS y
+ kernel_conf_variable DEVTMPFS_MOUNT y
+
+ # Newer inits like systemd need cgroup support
+ if [ "${KERNEL_ENABLE_CGROUPS}" = "1" ] ; then
+ kernel_conf_variable CGROUP_SCHED y
+ kernel_conf_variable CGROUPS y
+ kernel_conf_variable CGROUP_NS y
+ kernel_conf_variable CGROUP_FREEZER y
+ kernel_conf_variable CGROUP_DEVICE y
+ kernel_conf_variable CPUSETS y
+ kernel_conf_variable PROC_PID_CPUSET y
+ kernel_conf_variable CGROUP_CPUACCT y
+ kernel_conf_variable RESOURCE_COUNTERS y
+ fi
+
+ #
+ # root-over-nfs-over-usb-eth support. Limited, but should cover some cases.
+ # Enable this by setting a proper CMDLINE_NFSROOT_USB.
+ #
+ if [ ! -z "${CMDLINE_NFSROOT_USB}" ]; then
+ bbnote "Configuring the kernel for root-over-nfs-over-usb-eth with CMDLINE ${CMDLINE_NFSROOT_USB}"
+ kernel_conf_variable INET y
+ kernel_conf_variable IP_PNP y
+ kernel_conf_variable USB_GADGET y
+ kernel_conf_variable USB_GADGET_SELECTED y
+ kernel_conf_variable USB_ETH y
+ kernel_conf_variable NFS_FS y
+ kernel_conf_variable ROOT_NFS y
+ kernel_conf_variable CMDLINE \"${CMDLINE_NFSROOT_USB} ${CMDLINE_DEBUG}\"
+ fi
+
+ sed -e "${CONF_SED_SCRIPT}" \
+ < '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
}
do_configure_append() {
- if test -e scripts/Makefile.fwinst ; then
- sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
- fi
+ if test -e scripts/Makefile.fwinst ; then
+ sed -i -e "s:-m0644:-m 0644:g" scripts/Makefile.fwinst
+ fi
}
do_install_append() {
- oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH
+ oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}/src/linux-${KERNEL_VERSION} ARCH=$ARCH
}
PACKAGES =+ "kernel-headers"