aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2019-09-11 13:31:03 +0800
committerKhem Raj <raj.khem@gmail.com>2019-09-11 00:04:29 -0700
commit255b755381e4876f1fad0b1a8b6e4be1a3b37935 (patch)
tree8b576f83d038a508d4eed5ae8de7934d1faee48c /meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
parentc93f66d65a333dee1bd7b8dbb776ceedc715cf86 (diff)
downloadmeta-openembedded-contrib-255b755381e4876f1fad0b1a8b6e4be1a3b37935.tar.gz
pm-graph: upgrade 5.3 -> 5.5
This release has python3 support so updating python3 to RDEPENDS. python subprocess comes with python3-core, so removing from RDEPENDS. Removed patch, which is already merged in this release. Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb')
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
new file mode 100644
index 0000000000..63a9fa88e9
--- /dev/null
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Timing analysis tools for suspend/resume/boot"
+DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \
+in optimizing their linux stack's suspend/resume & boot time."
+HOMEPAGE = "https://01.org/pm-graph"
+LICENSE = "GPL-2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
+
+SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
+SRC_URI = "git://github.com/intel/pm-graph.git \
+ file://0001-Makefile-fix-multilib-build-failure.patch \
+ file://0001-sleepgraph.py-use-python3.patch \
+"
+S = "${WORKDIR}/git"
+
+COMPATIBLE_HOST='(i.86|x86_64).*'
+EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
+
+do_install() {
+ oe_runmake install
+}
+
+RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"