aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorFabio Estevam <festevam@denx.de>2023-01-17 11:34:34 -0300
committerKhem Raj <raj.khem@gmail.com>2023-01-17 08:27:45 -0800
commitc3f4c702aea64eecdf67f0af2ad22b9c3466f4e0 (patch)
treea4299f64a76536bdbaa5ca712ce52c1f27f03201 /meta-oe/recipes-graphics
parent642239db49ebcad902f8b9eca929580033917667 (diff)
downloadmeta-openembedded-contrib-c3f4c702aea64eecdf67f0af2ad22b9c3466f4e0.tar.gz
lvgl-demo-fb: Add recipe
Add a recipe for the LVGL framebuffer GUI demo. This allows to quickly test the LVGL framebuffer GUI demo application by running the "demo" binary. Signed-off-by: Fabio Estevam <festevam@denx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb b/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb
new file mode 100644
index 0000000000..3430c2491c
--- /dev/null
+++ b/meta-oe/recipes-graphics/lvgl/lvgl-demo-fb.bb
@@ -0,0 +1,17 @@
+SUMMARY = "LVGL Demo Application for Framebuffer"
+HOMEPAGE = "https://github.com/lvgl/lv_port_linux_frame_buffer"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=802d3d83ae80ef5f343050bf96cce3a4 \
+ file://lv_drivers/LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2 \
+ file://lvgl/LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
+
+SRC_URI = "gitsm://github.com/lvgl/lv_port_linux_frame_buffer.git;branch=master;protocol=https"
+SRCREV = "dd010430b959f40b8f25a51c76bc920cbc2550cc"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "DESTDIR=${D}"
+
+do_install() {
+ oe_runmake install
+}