aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-12-29 12:45:32 +0800
committerKhem Raj <raj.khem@gmail.com>2023-01-04 15:33:58 -0800
commit3cb99aebf828c8defeca6b94c49bd3bb254b1e24 (patch)
tree57aec8199fdeb6f9322fcfdd65671ce68466a6a1 /meta-oe/recipes-graphics
parentd8e50a9507da7441b1694b025df17b0c8484d44d (diff)
downloadmeta-openembedded-contrib-3cb99aebf828c8defeca6b94c49bd3bb254b1e24.tar.gz
fontforge: upgrade 20220308 -> 20230101
0001-cmake-Use-alternate-way-to-detect-libm.patch refreshed for newversion. Changelog: ========== Display the block name for reserved code points by4934 Don't respond to wheel scrolls for buttons/tabsets by4940 gfilechooser.c: fix behaviour when changing file type by4939 Better control-drag handling for line-adjacent points by4945 Fix resolution of program root by4956 Fix missed nonextcp edit by4958 Support ToUnicode extraction from PDFs for Type3 fonts by4961 Add resource file and Windows application manifest by4950 Fix name extraction for Type3 fonts from pdfs by4960 cmake: Install fonttools and pycontrib by4941 Fix InfoPlist.strings file name. by4962 Fix normalisation of absolute paths by4963 Handle non-array cm transforms while reading graphics stream from PDFs by4965 Fix rect extraction from graphics stream for type3 fonts by4967 Change which lookup types are suggested for jamo features by4994 Better line handling in simplify by4981 Use 'cmap' for Adobe-Identity-0 CID fonts by4993 Fix ChangeGlyph calcluations relative to new nonext/prevcp conventions by4979 Docs composite glyph by4971 FVSplineFontPieceMeal: Check that the clut is present before applying conversion by4999 Expand the lists of languages and scripts by4982 Add flags to Python font.transform() by4980 Support setting SplineChar width from importOutlines. by5005 Undefine "extended" macro temporarily on GNU Hurd by5047 Define PATH_MAX and MAXPATHLEN for GNU/Hurd compatibility by5046 Fix Ascent & Descent Importing from SVG Font by5035 Prevent floating point shenanigans in loop termination (fixes #5012) by5013 GroupFindLPos() in fontforgeexe/groupsdlg.c null pointer fix by5025 Fix drawing outside of expose calls by4949 Fixed one more typo by5055 Upgrade GitHub Actions by5014 Prevents memory underflow in GFileMimeType() in gutils/fsys.c by5018 Add a preference for saving editor state by5044 splineutil.c: prevent hang on nan input by5058 Shell-quote command sent to compressor in BDF by5060 Fix pfadecrypt bugs by5074 Include SFDUTF7 functions in libfontforge.so by5078 splinefit.c: Improvements to merge/simplify by5095 RFE: [FEAT] When reference to non-existent glyphs are present in an OpenTy by4097 docs: Python scripting - update font.mergeFeature with details of boo by5107 Fix logic for CharString double-movetos after PR 4685 by5120 Upgrade to Unicode 15.0.0 and fix and expand the script lists by5110 Fix broken link on scripting page by5135 Fix typo in man page by5106 Fix painting behaviour of the ruler linger window and layer change dialog by5163 fontinfo.c: fix crash from uninitialised other_pos by5165 tottfgpos: Fix needless warning about 16-bit field by5136 ufo.c: emit guidelines key by5166 fvmetrics.c: partial revert of 1033bc6 by5167 Update tranlsations from Crowdin by5168 Fix woff2 decoding by5160 Record unicode cmap encodings when one glyph is in multiple slots by4586 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge/0001-cmake-Use-alternate-way-to-detect-libm.patch24
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb (renamed from meta-oe/recipes-graphics/fontforge/fontforge_20220308.bb)2
2 files changed, 18 insertions, 8 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge/0001-cmake-Use-alternate-way-to-detect-libm.patch b/meta-oe/recipes-graphics/fontforge/fontforge/0001-cmake-Use-alternate-way-to-detect-libm.patch
index dd799e7485..573866eb15 100644
--- a/meta-oe/recipes-graphics/fontforge/fontforge/0001-cmake-Use-alternate-way-to-detect-libm.patch
+++ b/meta-oe/recipes-graphics/fontforge/fontforge/0001-cmake-Use-alternate-way-to-detect-libm.patch
@@ -1,4 +1,4 @@
-From 6d3c48d1b01943a467928235c3affbab463c25ab Mon Sep 17 00:00:00 2001
+From 644c3380f75b20a11755e7052aa632887f3eee2b Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 7 Jul 2022 12:32:47 -0700
Subject: [PATCH] cmake: Use alternate way to detect libm
@@ -8,17 +8,20 @@ when libm is folded into libc starting glibc 2.35+
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
CMakeLists.txt | 7 ++++++-
contrib/fonttools/CMakeLists.txt | 2 +-
fontforge/CMakeLists.txt | 2 +-
- fontforgeexe/CMakeLists.txt | 4 ++--
- 4 files changed, 10 insertions(+), 5 deletions(-)
+ fontforgeexe/CMakeLists.txt | 2 +-
+ 4 files changed, 9 insertions(+), 4 deletions(-)
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e234cb6e9..284ba2d20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -111,9 +111,14 @@ find_package_with_target(Intl REQUIRED)
- find_package(GLIB 2.6 REQUIRED COMPONENTS gio gobject)
+@@ -115,9 +115,14 @@ else()
+ endif()
find_package(Iconv REQUIRED)
find_package(LibXml2 REQUIRED)
-find_package(MathLib REQUIRED)
@@ -33,9 +36,11 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
check_include_file(pthread.h HAVE_PTHREAD_H)
if(HAVE_PTHREAD_H)
find_package(Threads)
+diff --git a/contrib/fonttools/CMakeLists.txt b/contrib/fonttools/CMakeLists.txt
+index d6c698877..1608af152 100644
--- a/contrib/fonttools/CMakeLists.txt
+++ b/contrib/fonttools/CMakeLists.txt
-@@ -15,6 +15,6 @@ add_executable(woff woff.c)
+@@ -15,7 +15,7 @@ add_executable(woff woff.c)
target_link_libraries(acorn2sfd PRIVATE fontforge)
target_link_libraries(dewoff PRIVATE ZLIB::ZLIB)
@@ -43,6 +48,9 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
+target_link_libraries(pcl2ttf PRIVATE ${EXTRA_LIBS})
target_link_libraries(ttf2eps PRIVATE fontforge)
target_link_libraries(woff PRIVATE ZLIB::ZLIB)
+
+diff --git a/fontforge/CMakeLists.txt b/fontforge/CMakeLists.txt
+index 9a052f360..067ef40df 100644
--- a/fontforge/CMakeLists.txt
+++ b/fontforge/CMakeLists.txt
@@ -237,7 +237,7 @@ target_link_libraries(fontforge
@@ -54,9 +62,11 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Iconv::Iconv
ZLIB::ZLIB
)
+diff --git a/fontforgeexe/CMakeLists.txt b/fontforgeexe/CMakeLists.txt
+index e2982c39d..8829993ea 100644
--- a/fontforgeexe/CMakeLists.txt
+++ b/fontforgeexe/CMakeLists.txt
-@@ -110,7 +110,7 @@ if(ENABLE_PYTHON_SCRIPTING_RESULT)
+@@ -121,7 +121,7 @@ if(ENABLE_PYTHON_SCRIPTING_RESULT)
target_link_libraries(fontforgeexe PRIVATE Python3::Python)
endif()
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20220308.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb
index ddb4443baa..2b425c583d 100644
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20220308.bb
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb
@@ -14,7 +14,7 @@ inherit cmake pkgconfig python3native python3targetconfig features_check gettext
REQUIRED_DISTRO_FEATURES:append:class-target = " x11"
# tag 20220308
-SRCREV = "582bd41a9bf04326300fc02a677fe3610d6d3ccd"
+SRCREV = "a1dad3e81da03d5d5f3c4c1c1b9b5ca5ebcfcecf"
SRC_URI = "git://github.com/${BPN}/${BPN}.git;branch=master;protocol=https \
file://0001-include-sys-select-on-non-glibc-platforms.patch \
file://0001-fontforgeexe-Use-env-to-find-fontforge.patch \