aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-graphics
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/clutter/clutter-box2d.inc4
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.09.bb6
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp_2.8.2.bb4
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb8
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb36
-rw-r--r--meta-oe/recipes-graphics/nonworking/slim/slim_1.3.2.bb70
-rw-r--r--meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb32
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib_git.bb6
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb4
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb2
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb10
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb4
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb12
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb6
-rw-r--r--meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb2
-rw-r--r--meta-oe/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb10
-rw-r--r--meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb14
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xterm_277.bb6
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb10
-rw-r--r--meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb2
-rw-r--r--meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.10.bb6
-rw-r--r--meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb26
-rw-r--r--meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb12
24 files changed, 148 insertions, 148 deletions
diff --git a/meta-oe/recipes-graphics/clutter/clutter-box2d.inc b/meta-oe/recipes-graphics/clutter/clutter-box2d.inc
index 056b091847..646b785ca7 100644
--- a/meta-oe/recipes-graphics/clutter/clutter-box2d.inc
+++ b/meta-oe/recipes-graphics/clutter/clutter-box2d.inc
@@ -8,8 +8,8 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit autotools pkgconfig gtk-doc
do_install_append () {
- install -d ${D}${bindir}
- install ${S}/examples/.libs/blockbox ${D}${bindir}
+ install -d ${D}${bindir}
+ install ${S}/examples/.libs/blockbox ${D}${bindir}
}
FILESPATH = "${FILE_DIRNAME}/clutter-box2d"
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.09.bb b/meta-oe/recipes-graphics/fbida/fbida_2.09.bb
index 455fd8a755..02ea57fd51 100644
--- a/meta-oe/recipes-graphics/fbida/fbida_2.09.bb
+++ b/meta-oe/recipes-graphics/fbida/fbida_2.09.bb
@@ -15,12 +15,12 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = "STRIP="
do_compile() {
- sed -i -e 's: cpp: ${TARGET_PREFIX}cpp:g' GNUmakefile
- oe_runmake
+ sed -i -e 's: cpp: ${TARGET_PREFIX}cpp:g' GNUmakefile
+ oe_runmake
}
do_install() {
- oe_runmake 'DESTDIR=${D}' install
+ oe_runmake 'DESTDIR=${D}' install
}
RDEPENDS_${PN} = "ttf-dejavu-sans-mono"
diff --git a/meta-oe/recipes-graphics/gimp/gimp_2.8.2.bb b/meta-oe/recipes-graphics/gimp/gimp_2.8.2.bb
index 44e66ea6d0..e9bbdcf70a 100644
--- a/meta-oe/recipes-graphics/gimp/gimp_2.8.2.bb
+++ b/meta-oe/recipes-graphics/gimp/gimp_2.8.2.bb
@@ -16,8 +16,8 @@ EXTRA_OECONF = "--disable-python \
--without-wmf"
do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
- find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
}
FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb
index 60271cc77c..fd547d9918 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.4.11.bb
@@ -26,10 +26,10 @@ inherit autotools pkgconfig gettext lib_package
EXTRA_OECONF = " --with-drivers=all udevscriptdir=/lib/udev ac_cv_lib_ltdl_lt_dlcaller_register=yes"
do_configure_append() {
- cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/libgphoto2_port/po/
- cd ${S}/libgphoto2_port/
- autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
- cd ${S}
+ cp ${STAGING_DATADIR}/gettext/po/Makefile.in.in ${S}/libgphoto2_port/po/
+ cd ${S}/libgphoto2_port/
+ autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
+ cd ${S}
}
do_install_append() {
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
index a6f266cc38..a24f75c654 100644
--- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -3,11 +3,11 @@ HOMEPAGE = "http://blog.lxde.org/?p=531"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
SRC_URI = " \
- git://lxde.git.sourceforge.net/gitroot/lxde/${BPN};protocol=git;branch=master \
- file://lxdm.conf \
- file://lxdm-pam \
- file://lxdm-pam-debug \
- ${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \
+ git://lxde.git.sourceforge.net/gitroot/lxde/${BPN};protocol=git;branch=master \
+ file://lxdm.conf \
+ file://lxdm-pam \
+ file://lxdm-pam-debug \
+ ${@base_contains("DISTRO_TYPE", "debug", "", "file://0001-lxdm.conf.in-blacklist-root-for-release-images.patch",d)} \
"
LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam",d)}"
@@ -29,22 +29,22 @@ S = "${WORKDIR}/git"
EXTRA_OECONF += "${@base_contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_unitdir}/system/', '--without-systemdsystemunitdir', d)}"
do_compile_append() {
- # default background configured not available / no password field available / no default screensaver
- sed -i -e 's,bg=,# bg=,g' \
- -e 's,# skip_password=,skip_password=,g' \
- -e 's,# arg=.*,arg=${bindir}/X -s 0,g' \
- ${S}/data/lxdm.conf.in
- # add default configuration
- oe_runmake -C ${S}/data lxdm.conf
+ # default background configured not available / no password field available / no default screensaver
+ sed -i -e 's,bg=,# bg=,g' \
+ -e 's,# skip_password=,skip_password=,g' \
+ -e 's,# arg=.*,arg=${bindir}/X -s 0,g' \
+ ${S}/data/lxdm.conf.in
+ # add default configuration
+ oe_runmake -C ${S}/data lxdm.conf
}
do_install_append() {
- install -d ${D}${localstatedir}/lib/lxdm
- install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm
- # ArchLinux version of pam config has the following advantages:
- # * simple setup of passwordless login
- # * in XFCE powerdown/restart enabled in logoff dialog
- install -m 644 ${WORKDIR}/${LXDM_PAM} ${D}${sysconfdir}/pam.d/lxdm
+ install -d ${D}${localstatedir}/lib/lxdm
+ install -m 644 ${WORKDIR}/lxdm.conf ${D}${localstatedir}/lib/lxdm
+ # ArchLinux version of pam config has the following advantages:
+ # * simple setup of passwordless login
+ # * in XFCE powerdown/restart enabled in logoff dialog
+ install -m 644 ${WORKDIR}/${LXDM_PAM} ${D}${sysconfdir}/pam.d/lxdm
}
# make installed languages choosable
diff --git a/meta-oe/recipes-graphics/nonworking/slim/slim_1.3.2.bb b/meta-oe/recipes-graphics/nonworking/slim/slim_1.3.2.bb
index 1428806b5a..57b47f6587 100644
--- a/meta-oe/recipes-graphics/nonworking/slim/slim_1.3.2.bb
+++ b/meta-oe/recipes-graphics/nonworking/slim/slim_1.3.2.bb
@@ -8,19 +8,19 @@ PR = "r1"
DEPENDS = "virtual/libx11 libxmu libpng jpeg freetype sessreg ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
SRC_URI = " \
- http://download.berlios.de/${PN}/${P}.tar.gz \
- file://0002-Fix-image-handling-integer-overflows.patch \
- file://0003-Fix-build-failure-with-ld-as-needed.patch \
- file://0004-Add-support-libpng15.patch \
- file://0005-Remove-path-of-gcc-amd-g-and-version-of-g.patch \
- file://0006-Remove-localhost-from-Authenticator-of-pam.patch \
- file://0007-Fix-tty-slowness.patch \
- file://0008-restart-Xserver-if-killed.patch \
- file://slim-dynwm \
- file://update_slim_wmlist \
- file://Makefile.oe \
- file://slim.pamd \
- file://slim.service \
+ http://download.berlios.de/${PN}/${P}.tar.gz \
+ file://0002-Fix-image-handling-integer-overflows.patch \
+ file://0003-Fix-build-failure-with-ld-as-needed.patch \
+ file://0004-Add-support-libpng15.patch \
+ file://0005-Remove-path-of-gcc-amd-g-and-version-of-g.patch \
+ file://0006-Remove-localhost-from-Authenticator-of-pam.patch \
+ file://0007-Fix-tty-slowness.patch \
+ file://0008-restart-Xserver-if-killed.patch \
+ file://slim-dynwm \
+ file://update_slim_wmlist \
+ file://Makefile.oe \
+ file://slim.pamd \
+ file://slim.service \
"
SRC_URI[md5sum] = "ca1ae6120e6f4b4969f2d6cf94f47b42"
@@ -28,32 +28,32 @@ SRC_URI[sha256sum] = "f1560125005f253b9b88220598fed7a9575ef405716862c6ca3fcc72db
EXTRA_OEMAKE += " \
- USE_PAM=${@base_contains('DISTRO_FEATURES', 'pam', '1', '0', d)} \
- PREFIX=${prefix} \
- CFGDIR=${sysconfdir} \
- MANDIR=${mandir} \
- DESTDIR=${D} \
- CFLAGS+=-I${STAGING_INCDIR}/freetype2 \
- CXXFLAGS+=-I${STAGING_INCDIR}/freetype2 \
+ USE_PAM=${@base_contains('DISTRO_FEATURES', 'pam', '1', '0', d)} \
+ PREFIX=${prefix} \
+ CFGDIR=${sysconfdir} \
+ MANDIR=${mandir} \
+ DESTDIR=${D} \
+ CFLAGS+=-I${STAGING_INCDIR}/freetype2 \
+ CXXFLAGS+=-I${STAGING_INCDIR}/freetype2 \
"
do_compile_prepend() {
- cp -pP ${WORKDIR}/Makefile.oe ${S}/Makefile
+ cp -pP ${WORKDIR}/Makefile.oe ${S}/Makefile
}
do_install() {
- oe_runmake install
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/slim-dynwm ${D}${bindir}/
- install -m 0755 ${WORKDIR}/update_slim_wmlist ${D}${bindir}/
- install -d ${D}${sysconfdir}/pam.d/
- install -m 0644 ${WORKDIR}/slim.pamd ${D}${sysconfdir}/pam.d/slim
-
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system/
-
- echo 'sessionstart_cmd /usr/bin/sessreg -a -l $DISPLAY %user' >> ${D}${sysconfdir}/slim.conf
- echo 'sessionstop_cmd /usr/bin/sessreg -d -l $DISPLAY %user' >> ${D}${sysconfdir}/slim.conf
+ oe_runmake install
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/slim-dynwm ${D}${bindir}/
+ install -m 0755 ${WORKDIR}/update_slim_wmlist ${D}${bindir}/
+ install -d ${D}${sysconfdir}/pam.d/
+ install -m 0644 ${WORKDIR}/slim.pamd ${D}${sysconfdir}/pam.d/slim
+
+ install -d ${D}${systemd_unitdir}/system/
+ install -m 0644 ${WORKDIR}/*.service ${D}${systemd_unitdir}/system/
+
+ echo 'sessionstart_cmd /usr/bin/sessreg -a -l $DISPLAY %user' >> ${D}${sysconfdir}/slim.conf
+ echo 'sessionstop_cmd /usr/bin/sessreg -d -l $DISPLAY %user' >> ${D}${sysconfdir}/slim.conf
}
@@ -62,7 +62,7 @@ FILES_${PN} += "${systemd_unitdir}/system/"
pkg_postinst_${PN} () {
if test "x$D" != "x"; then
- exit 1
+ exit 1
fi
systemctl enable slim.service
@@ -73,7 +73,7 @@ echo "${bindir}/slim" > ${sysconfdir}/X11/default-display-manager
pkg_postrm_${PN} () {
if test "x$D" != "x"; then
- exit 1
+ exit 1
fi
systemctl disable slim.service
sed -i /slim/d $D${sysconfdir}/X11/default-display-manager || true
diff --git a/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
index e05ff3843b..d6e0681d9e 100644
--- a/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
+++ b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
@@ -8,9 +8,9 @@ PR = "r2"
inherit packagegroup allarch
PACKAGES += "\
- ${PN}-core \
- ${PN}-chinese \
- ${PN}-japanese \
+ ${PN}-core \
+ ${PN}-chinese \
+ ${PN}-japanese \
"
RPROVIDES_${PN} += "task-fonts-truetype"
RPROVIDES_${PN}-core += "task-fonts-truetype-core"
@@ -26,27 +26,27 @@ RCONFLICTS_${PN}-chinese += "task-fonts-truetype-chinese"
RCONFLICTS_${PN}-japanese += "task-fonts-truetype-japanese"
RRECOMMENDS_${PN} = "\
- ${PN}-core \
- ${PN}-chinese \
- ${PN}-japanese \
+ ${PN}-core \
+ ${PN}-chinese \
+ ${PN}-japanese \
"
RDEPENDS_${PN}-core = "\
- fontconfig-utils \
- \
- ttf-dejavu-common \
- ttf-dejavu-sans \
- ttf-dejavu-sans-mono \
+ fontconfig-utils \
+ \
+ ttf-dejavu-common \
+ ttf-dejavu-sans \
+ ttf-dejavu-sans-mono \
"
# ttf-dejavu-serif
RDEPENDS_${PN}-chinese = "\
- ${PN}-core \
- ttf-arphic-uming \
+ ${PN}-core \
+ ttf-arphic-uming \
"
RDEPENDS_${PN}-japanese = "\
- ${PN}-core \
- ttf-sazanami-gothic \
- ttf-sazanami-mincho \
+ ${PN}-core \
+ ttf-sazanami-gothic \
+ ttf-sazanami-mincho \
"
diff --git a/meta-oe/recipes-graphics/tslib/tslib_git.bb b/meta-oe/recipes-graphics/tslib/tslib_git.bb
index 71a63ee942..b653978d47 100644
--- a/meta-oe/recipes-graphics/tslib/tslib_git.bb
+++ b/meta-oe/recipes-graphics/tslib/tslib_git.bb
@@ -28,12 +28,12 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00"
do_install_prepend() {
- install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
+ install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
}
do_install_append() {
- install -d ${D}${sysconfdir}/profile.d/
- install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
}
SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb
index bcc797cc23..72bc2d2559 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-dejavu_2.23.bb
@@ -20,8 +20,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/dejavu/dejavu-fonts-ttf-${PV}.tar.bz2 \
S = "${WORKDIR}/dejavu-fonts-ttf-${PV}/ttf"
do_install_append () {
- install -d ${D}${sysconfdir}/fonts/conf.d/
- install -m 0644 ${WORKDIR}/30-dejavu-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
+ install -d ${D}${sysconfdir}/fonts/conf.d/
+ install -m 0644 ${WORKDIR}/30-dejavu-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
}
PACKAGES = "\
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb
index a96bc51114..c1180b87ca 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-droid_git.bb
@@ -13,7 +13,7 @@ SRC_URI = "git://github.com/android/platform_frameworks_base.git;protocol=git;br
S = "${WORKDIR}/git/data/fonts"
do_install_prepend() {
- rm ${S}/Ahem.ttf MTLc3m.ttf DroidSansArabic.ttf DroidSansThai.ttf Clockopia.ttf MTLmr3m.ttf DroidSansHebrew.ttf DroidSansFallbackLegacy.ttf # we're not packaging it
+ rm ${S}/Ahem.ttf MTLc3m.ttf DroidSansArabic.ttf DroidSansThai.ttf Clockopia.ttf MTLmr3m.ttf DroidSansHebrew.ttf DroidSansFallbackLegacy.ttf # we're not packaging it
}
PACKAGES = "ttf-droid-sans ttf-droid-sans-mono \
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb
index 8359bd88f5..129e1375a0 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-inconsolata_20100526.bb
@@ -7,20 +7,20 @@ LIC_FILES_CHKSUM = "file://../OFL.txt;md5=969851e3a70122069a4d9ee61dd5a2ed"
PR = "r0"
SRC_URI = "http://levien.com/type/myfonts/Inconsolata.otf \
- file://OFL.txt"
+ file://OFL.txt"
S = "${WORKDIR}/ttf-inconsolata-${PV}"
FILES_${PN} = "${datadir}/fonts/truetype/Inconsolata.ttf \
- ${datadir}/doc/ttf-inconsolata/*"
+ ${datadir}/doc/ttf-inconsolata/*"
do_configure() {
- mv ${WORKDIR}/Inconsolata.otf ${S}/Inconsolata.ttf
+ mv ${WORKDIR}/Inconsolata.otf ${S}/Inconsolata.ttf
}
do_install_append() {
- install -d ${D}${datadir}/doc/ttf-inconsolata/
- install -m 0644 ${WORKDIR}/OFL.txt ${D}${datadir}/doc/ttf-inconsolata/
+ install -d ${D}${datadir}/doc/ttf-inconsolata/
+ install -m 0644 ${WORKDIR}/OFL.txt ${D}${datadir}/doc/ttf-inconsolata/
}
SRC_URI[md5sum] = "0fbe014c1f0fb5e3c71140ff0dc63edf"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
index 52379449d7..d2e84c2e2b 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
@@ -18,8 +18,8 @@ python populate_packages_prepend() {
}
do_install() {
- install -d ${D}${datadir}/fonts/ttf-mplus
- install -m 0644 *.ttf ${D}${datadir}/fonts/ttf-mplus/
+ install -d ${D}${datadir}/fonts/ttf-mplus
+ install -m 0644 *.ttf ${D}${datadir}/fonts/ttf-mplus/
}
SRC_URI[md5sum] = "d1400184b51b3871e8d2fca6c50e18ae"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb
index d883734894..0390740de3 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-sazanami_20040629.bb
@@ -23,12 +23,12 @@ FILES_ttf-sazanami-mincho = "${datadir}/fonts/truetype/sazanami-mincho.ttf \
${datadir}/doc/ttf-sazanami-mincho/README"
do_install_append() {
- # README contains the redistribution license
- install -d ${D}${datadir}/doc/
- install -d ${D}${datadir}/doc/ttf-sazanami-gothic
- install -d ${D}${datadir}/doc/ttf-sazanami-mincho
- install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-gothic
- install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-mincho
+ # README contains the redistribution license
+ install -d ${D}${datadir}/doc/
+ install -d ${D}${datadir}/doc/ttf-sazanami-gothic
+ install -d ${D}${datadir}/doc/ttf-sazanami-mincho
+ install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-gothic
+ install -m 0644 ${S}/README ${D}${datadir}/doc/ttf-sazanami-mincho
}
SRC_URI[md5sum] = "ceef10579a75c92483171f3bd7f77df2"
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb
index 6095386db3..88fca6c513 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-wqy-zenhei_0.6.26.bb
@@ -11,9 +11,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/wqy/wqy-zenhei-${PV}-0.tar.gz"
S = "${WORKDIR}/wqy-zenhei"
do_install_append () {
- install -d ${D}${sysconfdir}/fonts/conf.d/
- install -m 0644 ${S}/44-wqy-zenhei.conf ${D}${sysconfdir}/fonts/conf.d/
- install -m 0644 ${S}/66-wqy-zenhei-sharp.conf ${D}${sysconfdir}/fonts/conf.d/
+ install -d ${D}${sysconfdir}/fonts/conf.d/
+ install -m 0644 ${S}/44-wqy-zenhei.conf ${D}${sysconfdir}/fonts/conf.d/
+ install -m 0644 ${S}/66-wqy-zenhei-sharp.conf ${D}${sysconfdir}/fonts/conf.d/
}
PACKAGES = "${PN}"
diff --git a/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb b/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
index 4f13058327..a79b57f19f 100644
--- a/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
+++ b/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
@@ -14,6 +14,6 @@ SRC_URI[sha256sum] = "42d7271fbc796e53db71bb221f311b9ff3c51d90a71c9487a9bd3101ca
EXTRA_OEMAKE = "PREFIX=${prefix} INSTALLMAN=${mandir}"
do_install() {
- oe_runmake -e install DESTDIR=${D} PREFIX=${prefix}
+ oe_runmake -e install DESTDIR=${D} PREFIX=${prefix}
}
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb b/meta-oe/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
index 9b68d54e7a..bfb952f881 100644
--- a/meta-oe/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
+++ b/meta-oe/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
@@ -8,11 +8,11 @@ SRC_URI = "file://pointercal.xinput"
S = "${WORKDIR}"
do_install() {
- # Only install file if it has a contents
- if [ -s ${S}/pointercal.xinput ]; then
- install -d ${D}${sysconfdir}/
- install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/
- fi
+ # Only install file if it has a contents
+ if [ -s ${S}/pointercal.xinput ]; then
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/
+ fi
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
index b01f62dab0..593d4658c3 100644
--- a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
+++ b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
@@ -19,15 +19,15 @@ S = "${WORKDIR}/git"
EXTRA_OECONF += "--with-gui=x11"
do_install_append() {
- install -d ${D}${bindir}
- install -m 0755 scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh
+ install -d ${D}${bindir}
+ install -m 0755 scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh
- install -d ${D}${sysconfdir}/xdg/autostart
- sed -i -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' scripts/xinput_calibrator.desktop
- install -m 0644 scripts/xinput_calibrator.desktop ${D}${sysconfdir}/xdg/autostart
+ install -d ${D}${sysconfdir}/xdg/autostart
+ sed -i -e 's,^Exec=.*,Exec=${bindir}/xinput_calibrator_once.sh,' scripts/xinput_calibrator.desktop
+ install -m 0644 scripts/xinput_calibrator.desktop ${D}${sysconfdir}/xdg/autostart
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/xinput-calibrator.service ${D}${systemd_unitdir}/system
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/xinput-calibrator.service ${D}${systemd_unitdir}/system
}
FILES_${PN} += "${sysconfdir}/xdg/autostart"
diff --git a/meta-oe/recipes-graphics/xorg-app/xterm_277.bb b/meta-oe/recipes-graphics/xorg-app/xterm_277.bb
index 18abe35234..c56be09408 100644
--- a/meta-oe/recipes-graphics/xorg-app/xterm_277.bb
+++ b/meta-oe/recipes-graphics/xorg-app/xterm_277.bb
@@ -15,9 +15,9 @@ EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
--disable-setuid"
do_configure() {
- gnu-configize --force
- sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
- oe_runconf
+ gnu-configize --force
+ sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
+ oe_runconf
}
FILES_${PN} += " /usr/lib/X11"
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb
index a604d4651a..0397fb2f57 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-input-mtev_git.bb
@@ -16,6 +16,6 @@ EXTRA_OEMAKE = "'INCLUDE=-I${STAGING_INCDIR}/xorg -I${STAGING_INCDIR}/pixman-1'"
#skip xorg-driver-common.inc AC_CHECK_FILE mangling
do_configure_prepend () {
- sed 's#gcc#${CC}#g' -i Makefile
- return
+ sed 's#gcc#${CC}#g' -i Makefile
+ return
}
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb
index d00fb4eda5..fab7fab1fd 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-input-tslib_0.0.6.bb
@@ -22,13 +22,13 @@ SRC_URI[md5sum] = "b7a4d2f11637ee3fcf432e044b1d017f"
SRC_URI[sha256sum] = "5f46fdef095a6e44a69e0f0b57c7d665224b26d990d006611236d8332e85b105"
do_configure_prepend() {
- rm -rf ${S}/m4/ || true
+ rm -rf ${S}/m4/ || true
}
do_install_append() {
- install -d ${D}/${datadir}/hal/fdi/policy/20thirdparty
- install -m 0644 ${WORKDIR}/10-x11-input-tslib.fdi ${D}/${datadir}/hal/fdi/policy/20thirdparty
- install -d ${D}/lib/udev/rules.d
- install -m 0644 ${WORKDIR}/99-xf86-input-tslib.rules ${D}/lib/udev/rules.d/
+ install -d ${D}/${datadir}/hal/fdi/policy/20thirdparty
+ install -m 0644 ${WORKDIR}/10-x11-input-tslib.fdi ${D}/${datadir}/hal/fdi/policy/20thirdparty
+ install -d ${D}/lib/udev/rules.d
+ install -m 0644 ${WORKDIR}/99-xf86-input-tslib.rules ${D}/lib/udev/rules.d/
}
FILES_${PN} += "${datadir}/hal /lib/udev"
diff --git a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
index f9eb3ce920..c3d83a47d2 100644
--- a/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
+++ b/meta-oe/recipes-graphics/xorg-driver/xf86-video-glamo_git.bb
@@ -14,7 +14,7 @@ SRC_URI = "git://git.openmoko.org/git/xf86-video-glamo.git;protocol=git;branch=m
file://0001-fix-build-with-KMS-disabled.patch \
file://0003-glamo-driver-adapt-to-xserver-0.13-video-API.patch \
file://0001-glamo-driver-remove-references-to-mibstore.patch \
- "
+"
S = "${WORKDIR}/git"
SRCREV = "cb9ed17035a79e49dde26a1e7e2bc5f10fd8144b"
diff --git a/meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.10.bb b/meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.10.bb
index f5a4a6f6af..83cd1f901b 100644
--- a/meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.10.bb
+++ b/meta-oe/recipes-graphics/xorg-lib/libxaw_1.0.10.bb
@@ -14,9 +14,9 @@ SRC_URI[sha256sum] = "2d96bcf92638b8ec5c91d379f5ec2e7b15133adeb2ba22066d48bf3239
EXTRA_OECONF += " --disable-docs "
do_install_append () {
- ln -sf libXaw6.so.6 ${D}${libdir}/libXaw.so.6
- ln -sf libXaw7.so.7 ${D}${libdir}/libXaw.so.7
- ln -sf libXaw7.so.7 ${D}${libdir}/libXaw.so
+ ln -sf libXaw6.so.6 ${D}${libdir}/libXaw.so.6
+ ln -sf libXaw7.so.7 ${D}${libdir}/libXaw.so.7
+ ln -sf libXaw7.so.7 ${D}${libdir}/libXaw.so
}
PACKAGES =+ "libxaw6 libxaw7 libxaw8"
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
index f3074196f4..3bb8b61a8d 100644
--- a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
+++ b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
@@ -11,22 +11,22 @@ SRC_URI[md5sum] = "82f2f84cd96610e8f7b92c700cd31c14"
SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166cc34210"
SRC_URI_append = " \
- file://0001-COPYING-add-GPLv2-license-file.patch \
- file://0002-add-setdpi-Xinit.d-script.patch \
- file://0003-add-89xdgautostart-Xsession.d-script.patch \
- file://0005-add-XWindowManager-Xsession.d-script.patch \
- file://0006-add-support-for-etc-X11-xserver-system.patch \
- file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \
- file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \
- file://0009-xserver-common-add-support-for-n900-alias-nokia_rx-5.patch \
- file://0010-xserver-common-add-support-for-nexus-S-alias-herring.patch \
- file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \
- file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \
- file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \
+ file://0001-COPYING-add-GPLv2-license-file.patch \
+ file://0002-add-setdpi-Xinit.d-script.patch \
+ file://0003-add-89xdgautostart-Xsession.d-script.patch \
+ file://0005-add-XWindowManager-Xsession.d-script.patch \
+ file://0006-add-support-for-etc-X11-xserver-system.patch \
+ file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \
+ file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \
+ file://0009-xserver-common-add-support-for-n900-alias-nokia_rx-5.patch \
+ file://0010-xserver-common-add-support-for-nexus-S-alias-herring.patch \
+ file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \
+ file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \
+ file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \
"
do_install_append() {
- sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
+ sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
}
inherit allarch
diff --git a/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb b/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
index bbed445fe3..aa85c8c979 100644
--- a/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
+++ b/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
@@ -19,13 +19,13 @@ INITSCRIPT_PARAMS = "start 01 5 2 . stop 01 0 1 6 ."
INITSCRIPT_PARAMS_shr = "start 90 5 2 . stop 90 0 1 6 ."
do_install() {
- install -d ${D}${sysconfdir}/init.d
- install xserver-nodm ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/init.d
+ install xserver-nodm ${D}${sysconfdir}/init.d
- install -d ${D}${sysconfdir}/default
- install -d ${D}${systemd_unitdir}/system
- install xserver-nodm.conf ${D}${sysconfdir}/default/xserver-nodm
- install -m 0644 ${WORKDIR}/xserver-nodm.service ${D}${systemd_unitdir}/system
+ install -d ${D}${sysconfdir}/default
+ install -d ${D}${systemd_unitdir}/system
+ install xserver-nodm.conf ${D}${sysconfdir}/default/xserver-nodm
+ install -m 0644 ${WORKDIR}/xserver-nodm.service ${D}${systemd_unitdir}/system
}
RDEPENDS_${PN} = "xserver-common (>= 1.30) xinit"