aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-02 19:04:15 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-13 11:19:11 +0100
commita14aa989b93f86712d3440728eee650d2fa8fdf0 (patch)
tree69ad39e399fd4c3cb0f580bf868678b1949b459d /meta-oe/recipes-graphics
parentd9b5870edaddee69612dada2aa4bc2d8c3f70f44 (diff)
downloadmeta-openembedded-contrib-a14aa989b93f86712d3440728eee650d2fa8fdf0.tar.gz
libvncserver: Fix build with security flags on and disable libva
When libva is present it detects it and then fails to build until the support is fixed, lets disable it Add a patch to fix issue found when compiling with security flags turned on Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/libvncserver/libvncserver/0002-format_string.patch21
-rw-r--r--meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.10.bb3
2 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libvncserver/libvncserver/0002-format_string.patch b/meta-oe/recipes-graphics/libvncserver/libvncserver/0002-format_string.patch
new file mode 100644
index 0000000000..566a2087c8
--- /dev/null
+++ b/meta-oe/recipes-graphics/libvncserver/libvncserver/0002-format_string.patch
@@ -0,0 +1,21 @@
+From: Luca Falavigna <dktrkranz@debian.org>
+Date: Tue, 27 Jan 2015 01:26:04 +0000
+Subject: format_string
+
+---
+ client_examples/gtkvncviewer.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/client_examples/gtkvncviewer.c b/client_examples/gtkvncviewer.c
+index 261b2da..861e4e3 100644
+--- a/client_examples/gtkvncviewer.c
++++ b/client_examples/gtkvncviewer.c
+@@ -588,7 +588,7 @@ static void GtkDefaultLog (const char *format, ...)
+
+ time (&log_clock);
+ strftime (buf, 255, "%d/%m/%Y %X ", localtime (&log_clock));
+- fprintf (stdout, buf);
++ fprintf (stdout, "%s", buf);
+
+ vfprintf (stdout, format, args);
+ fflush (stdout);
diff --git a/meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.10.bb b/meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.10.bb
index 387202bee7..0eba87c5b2 100644
--- a/meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.10.bb
+++ b/meta-oe/recipes-graphics/libvncserver/libvncserver_0.9.10.bb
@@ -14,6 +14,7 @@ SRC_URI = "\
${DEBIAN_MIRROR}/main/libv/libvncserver/libvncserver_0.9.10+dfsg.orig.tar.xz \
file://0001-remove-webclients-build.patch \
file://0002-common-add-sha1.patch \
+ file://0002-format_string.patch \
"
SRC_URI[md5sum] = "e883b6c7bd339a5e1c48645051abe5c4"
@@ -21,4 +22,6 @@ SRC_URI[sha256sum] = "583f28869b82aec57768d7d18cd7ff81bf092ecbbc1209b587c2c2cd68
S = "${WORKDIR}/${BPN}-LibVNCServer-${PV}"
+EXTRA_OECONF += "--without-libva"
+
TARGET_LDFLAGS += "-lgcrypt"