aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorAnn Thornton <ann.thornton@nxp.com>2016-09-06 17:08:57 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-15 10:22:45 +0200
commit5b4a5572650e8a20c4a5c956d1874813f81c2d1b (patch)
tree79c3cd0406ed8b087dcdda44ee9fa47c224ad969 /meta-oe/recipes-graphics
parentf3cd93f4bd7d77e3f75076e53bffff3425c2ee98 (diff)
downloadmeta-openembedded-contrib-5b4a5572650e8a20c4a5c956d1874813f81c2d1b.tar.gz
glcompbench: Fix issues causing failures in GCC6
Signed-off-by: Ann Thornton <ann.thornton@nxp.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rwxr-xr-xmeta-oe/recipes-graphics/glcompbench/glcompbench/Fix-configure-for-sqrt-check.patch14
-rwxr-xr-xmeta-oe/recipes-graphics/glcompbench/glcompbench/Fix_auto_ptr_deprecated.patch24
-rwxr-xr-xmeta-oe/recipes-graphics/glcompbench/glcompbench/Fix_space_issues.patch22
-rwxr-xr-x[-rw-r--r--]meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb8
4 files changed, 64 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix-configure-for-sqrt-check.patch b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix-configure-for-sqrt-check.patch
new file mode 100755
index 0000000000..4831c401f6
--- /dev/null
+++ b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix-configure-for-sqrt-check.patch
@@ -0,0 +1,14 @@
+Index: git/wscript
+===================================================================
+--- git.orig/wscript 2016-07-29 13:15:44.954249796 -0500
++++ git/wscript 2016-07-29 15:52:06.196768865 -0500
+@@ -56,7 +56,7 @@
+ ctx.check_cxx(lib = lib, uselib_store = uselib)
+
+ # Check required functions
+- req_funcs = [('gettimeofday', 'sys/time.h', []) ,('sqrt', 'math.h', ['m']),
++ req_funcs = [('gettimeofday', 'sys/time.h', []),
+ ('strtol', 'stdlib.h', []), ('strtoul', 'stdlib.h', [])]
+ for func, header, uselib in req_funcs:
+ ctx.check_cxx(function_name = func, header_name = header, uselib = uselib, mandatory = True)
+
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_auto_ptr_deprecated.patch b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_auto_ptr_deprecated.patch
new file mode 100755
index 0000000000..930c7cb503
--- /dev/null
+++ b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_auto_ptr_deprecated.patch
@@ -0,0 +1,24 @@
+diff -aur glcompbench-2012.08/src/libmatrix/shader-source.cc Fixed/src/libmatrix/shader-source.cc
+--- glcompbench-2012.08/src/libmatrix/shader-source.cc 2012-08-22 13:41:36.000000000 -0500
++++ Fixed/src/libmatrix/shader-source.cc 2016-08-24 14:23:49.576023317 -0500
+@@ -34,7 +34,7 @@
+ bool
+ ShaderSource::load_file(const std::string& filename, std::string& str)
+ {
+- std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename));
++ std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename));
+ std::istream& inputFile(*is_ptr);
+
+ if (!inputFile)
+diff -aur glcompbench-2012.08/src/texture.cc Fixed/src/texture.cc
+--- glcompbench-2012.08/src/texture.cc 2012-08-22 13:41:36.000000000 -0500
++++ Fixed/src/texture.cc 2016-08-24 14:23:28.223917438 -0500
+@@ -52,7 +52,7 @@
+
+ Log::debug("Reading PNG file %s\n", filename.c_str());
+
+- const std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename));
++ const std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename));
+ if (!(*is_ptr)) {
+ Log::error("Cannot open file %s!\n", filename.c_str());
+ return false;
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_space_issues.patch b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_space_issues.patch
new file mode 100755
index 0000000000..516baadaea
--- /dev/null
+++ b/meta-oe/recipes-graphics/glcompbench/glcompbench/Fix_space_issues.patch
@@ -0,0 +1,22 @@
+diff -aur glcompbench-2012.08/src/composite-canvas.cc Fixed/src/composite-canvas.cc
+--- glcompbench-2012.08/src/composite-canvas.cc 2012-08-22 13:41:36.000000000 -0500
++++ Fixed/src/composite-canvas.cc 2016-08-24 14:05:28.970565709 -0500
+@@ -41,7 +41,7 @@
+ #include "log.h"
+ #include "profiler.h"
+
+-const std::string glcompbench_version_string("glcompbench "GLCOMPBENCH_VERSION);
++const std::string glcompbench_version_string("glcompbench " GLCOMPBENCH_VERSION);
+
+ /*******************
+ * Private methods *
+@@ -495,7 +495,7 @@
+ // When we complete an iteration, reset the count and tell the caller.
+
+ if (stats.total >= current_test_duration_) {
+- Log::info("FPS: %"PRIu64"\n", (uint64_t)(1000 * stats.nsamples / stats.total));
++ Log::info("FPS: %" PRIu64 "\n", (uint64_t)(1000 * stats.nsamples / stats.total));
+
+ for (Profiler::Point p = 0; p < profiler.get_num_points(); p += 2) {
+ profiler.get_stats(p, p + 1, stats);
+
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
index 0c5d7b5fc3..35fb4adb33 100644..100755
--- a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
+++ b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
@@ -6,7 +6,10 @@ DEPENDS = "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2 \
virtual/libx11 libxcomposite pixman libxrender libpng12"
SRC_URI = "https://launchpad.net/glcompbench/trunk/${PV}/+download/${BPN}-${PV}.tar.gz \
- file://glbench-compile-fix.patch"
+ file://glbench-compile-fix.patch \
+ file://Fix-configure-for-sqrt-check.patch \
+ file://Fix_space_issues.patch \
+ file://Fix_auto_ptr_deprecated.patch"
SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827"
SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee"
@@ -14,6 +17,3 @@ SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b037
inherit pkgconfig waf distro_features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
-
-# http://errors.yoctoproject.org/Errors/Details/68631/
-PNBLACKLIST[glcompbench] ?= "BROKEN: fails to build with gcc-6"