aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-15 23:01:33 -0700
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:13:55 -0700
commitde21729a76518eaf639151964a8e7dc056113eda (patch)
treefd9f117ecf10d721b4e0e3141d981b93de61f016 /meta-oe/recipes-graphics
parent9a170f1b6268afb56fb71fb1dc0161ff31f4cecd (diff)
downloadmeta-openembedded-contrib-de21729a76518eaf639151964a8e7dc056113eda.tar.gz
libyui: Fix build with gcc8
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch48
-rw-r--r--meta-oe/recipes-graphics/libyui/libyui_git.bb1
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch b/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch
new file mode 100644
index 0000000000..c1ba42eeed
--- /dev/null
+++ b/meta-oe/recipes-graphics/libyui/libyui/0001-Fix-GCC-8-warning.patch
@@ -0,0 +1,48 @@
+From 1e6d40fec16a94d1a4bd40634405267200b7e969 Mon Sep 17 00:00:00 2001
+From: marxin <mliska@suse.cz>
+Date: Tue, 10 Apr 2018 15:21:40 +0200
+Subject: [PATCH] Fix GCC 8 warning:
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+/home/marxin/Programming/libyui/src/YDialog.cc: In static member function ‘static void YDialog::showText(const string&, bool)’:
+/home/marxin/Programming/libyui/src/YDialog.cc:690:26: error: catching polymorphic type ‘class YUIException’ by value [-Werror=catch-value=]
+ catch ( YUIException exception )
+ ^~~~~~~~~
+/home/marxin/Programming/libyui/src/YDialog.cc: In static member function ‘static bool YDialog::showRelNotesText()’:
+/home/marxin/Programming/libyui/src/YDialog.cc:814:26: error: catching polymorphic type ‘class YUIException’ by value [-Werror=catch-value=]
+ catch ( YUIException exception )
+ ^~~~~~~~~
+---
+Upstream-Status: Submitted [https://github.com/libyui/libyui/pull/122]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+ src/YDialog.cc | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/YDialog.cc b/src/YDialog.cc
+index 92e5031..8ecff90 100644
+--- a/src/YDialog.cc
++++ b/src/YDialog.cc
+@@ -687,7 +687,7 @@ YDialog::showText( const std::string & text, bool useRichText )
+ dialog->waitForEvent();
+ dialog->destroy();
+ }
+- catch ( YUIException exception )
++ catch ( YUIException &exception )
+ {
+ // Don't let the application die just because help couldn't be displayed.
+
+@@ -811,7 +811,7 @@ YDialog::showRelNotesText()
+ }
+ dialog->destroy();
+ }
+- catch ( YUIException exception )
++ catch ( YUIException &exception )
+ {
+ // Don't let the application die just because RN couldn't be displayed.
+
+--
+2.17.0
+
diff --git a/meta-oe/recipes-graphics/libyui/libyui_git.bb b/meta-oe/recipes-graphics/libyui/libyui_git.bb
index 92d96044ec..e46e365b24 100644
--- a/meta-oe/recipes-graphics/libyui/libyui_git.bb
+++ b/meta-oe/recipes-graphics/libyui/libyui_git.bb
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
"
SRC_URI = "git://github.com/libyui/libyui.git \
+ file://0001-Fix-GCC-8-warning.patch \
"
PV = "3.3.3+git"