aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-04-21 12:08:35 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-04-21 12:10:27 +0200
commit09c8584833c91d64975c042696d1c204a883e6d8 (patch)
tree70055326aad03b77a0b52770b629e7e35d397794 /meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
parent2a9e3855e866da3cdcaac3c31720672bfafbe236 (diff)
downloadmeta-openembedded-contrib-09c8584833c91d64975c042696d1c204a883e6d8.tar.gz
xserver-common 1.34: make it work with xserver-nodm-init
* Move SHR patches to main SRC_URI, they are generic and good enough for everyone * Start x-window-manager * Run through oe-stylize * Remove duplicated LICENSE * Add reconflicts with x11-common as well Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb')
-rw-r--r--meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb38
1 files changed, 19 insertions, 19 deletions
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
index b994dfb4e6..0d59ab7dae 100644
--- a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
+++ b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
@@ -1,14 +1,8 @@
DESCRIPTION = "Common X11 scripts and support files"
-LICENSE = "GPL"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo fbset"
-PR = "r1"
-PACKAGE_ARCH = "all"
-
-RCONFLICTS_${PN} = "xserver-kdrive-common"
-RREPLACES_${PN} = "xserver-kdrive-common"
+PR = "r2"
# we are using a gpe-style Makefile
inherit gpe
@@ -19,20 +13,26 @@ SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166c
SRC_URI_append = " \
file://gplv2-license.patch \
file://setDPI.sh \
- file://89xdgautostart.sh"
+ file://89xdgautostart.sh \
+ file://89xTs_Calibrate.xinput_calibrator.patch \
+ file://90xXWindowManager.patch \
+ file://Xserver.add.xserver-system.patch \
+ file://Xserver.add.nocursor.for.gta.patch \
+ file://Xserver.add.dpi.for.gta.patch \
+ file://Xserver.n900.patch \
+"
-RDEPENDS_${PN}_append_shr = " xinput-calibrator "
-
-SRC_URI_append_shr = " file://89xTs_Calibrate.xinput_calibrator.patch \
- file://90xXWindowManager.patch \
- file://Xserver.add.nocursor.for.gta.patch \
- file://Xserver.add.xserver-system.patch \
- file://Xserver.add.dpi.for.gta.patch \
- file://Xserver.n900.patch"
do_install_append() {
- install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
- install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
- sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+ install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
+ sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
}
+PACKAGE_ARCH = "all"
+
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo fbset xinput-calibrator"
+
+RCONFLICTS_${PN} = "xserver-kdrive-common x11-common"
+RREPLACES_${PN} = "xserver-kdrive-common x11-common"
+