aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/xorg-app/xterm
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-05-16 23:37:43 -0700
committerKhem Raj <raj.khem@gmail.com>2024-05-19 08:28:00 -0700
commitaeb11d81dc5727bba91d79e4e6cc91d220f0a5f9 (patch)
treeab2a7a2d75cb1b3f8481061583045378c8909e79 /meta-oe/recipes-graphics/xorg-app/xterm
parent13ddd97e4f3b2557aa1aea1212e8003a503415ee (diff)
downloadmeta-openembedded-contrib-aeb11d81dc5727bba91d79e4e6cc91d220f0a5f9.tar.gz
xterm: Upgrade to 391
Add a patch to fix build with musl Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/xorg-app/xterm')
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xterm/0001-Add-configure-time-check-for-setsid.patch75
-rw-r--r--meta-oe/recipes-graphics/xorg-app/xterm/0001-include-missing-pty.h-header-for-openpty.patch30
2 files changed, 30 insertions, 75 deletions
diff --git a/meta-oe/recipes-graphics/xorg-app/xterm/0001-Add-configure-time-check-for-setsid.patch b/meta-oe/recipes-graphics/xorg-app/xterm/0001-Add-configure-time-check-for-setsid.patch
deleted file mode 100644
index a6cf16e4e9..0000000000
--- a/meta-oe/recipes-graphics/xorg-app/xterm/0001-Add-configure-time-check-for-setsid.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From b23d38f1216c4d70738edaa367cf9ecd2dd4b660 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 13 Dec 2019 12:59:26 -0800
-Subject: [PATCH] Add configure time check for setsid
-
-Do not assume glibc == linux
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
----
- configure | 1 +
- configure.in | 1 +
- main.c | 4 ++--
- xtermcfg.hin | 1 +
- 4 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/configure b/configure
-index 72342c7..c2ec2ac 100755
---- a/configure
-+++ b/configure
-@@ -5803,6 +5803,7 @@ for ac_func in \
- unsetenv \
- sched_yield \
- setpgid \
-+ setsid \
- strftime \
- tcgetattr \
- waitpid \
-diff --git a/configure.in b/configure.in
-index 56dbc25..0608c80 100644
---- a/configure.in
-+++ b/configure.in
-@@ -99,6 +99,7 @@ AC_CHECK_FUNCS( \
- unsetenv \
- sched_yield \
- setpgid \
-+ setsid \
- strftime \
- tcgetattr \
- waitpid \
-diff --git a/main.c b/main.c
-index 24da0eb..332174c 100644
---- a/main.c
-+++ b/main.c
-@@ -2956,7 +2956,7 @@ main(int argc, char *argv[]ENVP_ARG)
- }
- }
-
--#if defined(__osf__) || (defined(__GLIBC__) && !defined(USE_USG_PTYS)) || defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__APPLE__)
-+#if defined(__osf__) || (defined(__linux__) && !defined(USE_USG_PTYS)) || defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__APPLE__)
- #define USE_OPENPTY 1
- static int opened_tty = -1;
- #endif
-@@ -4205,7 +4205,7 @@ spawnXTerm(XtermWidget xw, unsigned line_speed)
- /*
- * now in child process
- */
--#if defined(_POSIX_SOURCE) || defined(SVR4) || defined(__convex__) || defined(__SCO__) || defined(__QNX__)
-+#if HAVE_SETSID
- int pgrp = setsid(); /* variable may not be used... */
- #else
- int pgrp = getpid();
-diff --git a/xtermcfg.hin b/xtermcfg.hin
-index 19048cd..e54d2cd 100644
---- a/xtermcfg.hin
-+++ b/xtermcfg.hin
-@@ -98,6 +98,7 @@
- #undef HAVE_SCHED_YIELD /* AC_CHECK_FUNCS(sched_yield) */
- #undef HAVE_SETITIMER /* CF_SETITIMER */
- #undef HAVE_SETPGID /* AC_CHECK_FUNCS(setpgid) */
-+#undef HAVE_SETSID /* AC_CHECK_FUNCS(setsid) */
- #undef HAVE_STDINT_H /* AC_PROG_CC_STDC */
- #undef HAVE_STDLIB_H /* AC_CHECK_HEADERS(stdlib.h) */
- #undef HAVE_STDNORETURN_H /* CF_C11_NORETURN */
diff --git a/meta-oe/recipes-graphics/xorg-app/xterm/0001-include-missing-pty.h-header-for-openpty.patch b/meta-oe/recipes-graphics/xorg-app/xterm/0001-include-missing-pty.h-header-for-openpty.patch
new file mode 100644
index 0000000000..0c9d64c82c
--- /dev/null
+++ b/meta-oe/recipes-graphics/xorg-app/xterm/0001-include-missing-pty.h-header-for-openpty.patch
@@ -0,0 +1,30 @@
+From e30ab2d73a21bc55511cbedbb9ae603246dbfcd1 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 16 May 2024 23:10:00 -0700
+Subject: [PATCH] include missing pty.h header for openpty()
+
+On musl this problem is unearthed
+
+Fix
+./main.c: In function 'get_pty':
+./main.c:3123:14: error: implicit declaration of function 'openpty'; did you mean 'openat'? [-Wimplicit-function-declaration]
+ 3123 | result = openpty(pty, &opened_tty, ttydev, NULL, NULL);
+ | ^~~~~~~
+ | openat
+
+Upstream-Status: Submitted [sent to dickey@invisible-island.net]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/main.c
++++ b/main.c
+@@ -89,6 +89,7 @@
+
+ #define RES_OFFSET(field) XtOffsetOf(XTERM_RESOURCE, field)
+
++#include <pty.h>
+ #include <xterm.h>
+ #include <version.h>
+ #include <graphics.h>