aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/x11vnc
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-05-17 09:10:20 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-05-27 15:39:09 +0200
commitf6db87726d84976275cfe6b74a9e270f6bf6792e (patch)
tree4310bb2e413f511af020693674326e6ad757ebbe /meta-oe/recipes-graphics/x11vnc
parenta3d4309facf0ea261adad867e34a262e8db51b16 (diff)
downloadmeta-openembedded-contrib-f6db87726d84976275cfe6b74a9e270f6bf6792e.tar.gz
x11vnc: remove old libtool macros from acinclude.m4
These can cause build problems. We only want macros in acinclude.m4 which aren't available for aclocal to get elsewhere. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/x11vnc')
-rw-r--r--meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
index 7e92965cc2..64c8a5d5d2 100644
--- a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
+++ b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
@@ -24,3 +24,9 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi',
PACKAGECONFIG[avahi] = "--with-avahi,--without-avahi,avahi"
PACKAGECONFIG[xinerama] = "--with-xinerama,--without-xinerama,libxinerama"
PACKAGECONFIG[libvncserver] = "--with-system-libvncserver,--without-system-libvncserver,libvncserver"
+
+do_prepare_sources () {
+ # Remove old libtool macros from acinclude.m4
+ sed -i -e '/^# libtool.m4/q' acinclude.m4
+}
+do_patch[postfuncs] += "do_prepare_sources"