aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/wayland
diff options
context:
space:
mode:
authorManuel Bachmann <manuel.bachmann@iot.bzh>2015-09-22 21:18:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:27:48 +0200
commitbf4cd19e95c82c50e30803a2cf1adda78da426d3 (patch)
tree5355db9f70147cf84546e59cc6da2dbd537d9df5 /meta-oe/recipes-graphics/wayland
parent5ea852737c3406494ffefbf71aba2a2c4d25def7 (diff)
downloadmeta-openembedded-contrib-bf4cd19e95c82c50e30803a2cf1adda78da426d3.tar.gz
wayland-fits: Add recipe
wayland-fits is a functional integration test suite for Wayland and Weston. MJ: removed elementary from default PACKAGECONFIG because meta-oe doesn't depend on meta-efl It optionally supports EFL and GTK+ tests. Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/wayland')
-rwxr-xr-xmeta-oe/recipes-graphics/wayland/wayland-fits_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/wayland/wayland-fits_git.bb b/meta-oe/recipes-graphics/wayland/wayland-fits_git.bb
new file mode 100755
index 0000000000..b74c44a633
--- /dev/null
+++ b/meta-oe/recipes-graphics/wayland/wayland-fits_git.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Wayland-fits, the Wayland Functional Integration Test Suite"
+DESCRIPTION = "Wayland-fits is a fully automated functional integration \
+test suite. Its main purpose is to test the functionality and integration of \
+client-side (i.e. toolkit) and server-side (compositor) implementations of \
+the Wayland protocol."
+HOMEPAGE = "https://github.com/01org/wayland-fits"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f8d34cadaf891753c0f00c6cd48f08f5 \
+ file://src/extensions/weston/weston-wfits.cpp;endline=21;md5=848c81e55cf3a30a9f6ed75f0dba7a97"
+
+SRC_URI = "git://github.com/01org/wayland-fits.git"
+SRCREV = "f30dfa9fceb438d3687c5215093fffc21a7852fc"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+DEPENDS = "libcheck boost wayland weston"
+RDEPENDS_${PN} = "weston"
+
+EXTRA_OECONF += "--enable-shared --disable-static --with-boost-libdir=${STAGING_LIBDIR}"
+
+PACKAGECONFIG ?= "gtk+3"
+
+PACKAGECONFIG[elementary] = "--enable-efl-tests,--disable-efl-tests,elementary"
+PACKAGECONFIG[gtk+3] = "--enable-gtk-tests,--disable-gtk-tests,gtk+3"
+
+do_install_append() {
+ rm -f ${D}/${libdir}/weston/*.la
+}
+
+FILES_${PN} += "${bindir}/wfits ${libdir}/weston/*.so"
+FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/weston/.debug ${prefix}/src"