aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/unclutter-xfixes/unclutter-xfixes_1.5.bb
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2019-09-13 11:43:07 +0200
committerKhem Raj <raj.khem@gmail.com>2019-09-13 09:26:09 -0700
commit184cf325c1c430b0e9ea23c6976ddad750fe29d3 (patch)
treeb78c991ca4375073a271160666910628c624fbb8 /meta-oe/recipes-graphics/unclutter-xfixes/unclutter-xfixes_1.5.bb
parent7c69fbdfd33407b2b04cc9c671480023f0f9bf47 (diff)
downloadmeta-openembedded-contrib-184cf325c1c430b0e9ea23c6976ddad750fe29d3.tar.gz
unclutter-xfixes: new package
Add a recipe for unclutter-xfixes - a rewrite of the popular tool unclutter using the x11-xfixes extension. Included is a patch adding autotools support (instead of a hand-coded Makefile) that's already been submitted upstream. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/unclutter-xfixes/unclutter-xfixes_1.5.bb')
-rw-r--r--meta-oe/recipes-graphics/unclutter-xfixes/unclutter-xfixes_1.5.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/unclutter-xfixes/unclutter-xfixes_1.5.bb b/meta-oe/recipes-graphics/unclutter-xfixes/unclutter-xfixes_1.5.bb
new file mode 100644
index 0000000000..a566bc18a3
--- /dev/null
+++ b/meta-oe/recipes-graphics/unclutter-xfixes/unclutter-xfixes_1.5.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Remove idle cursor image from screen."
+DESCRIPTION = "This is a rewrite of the popular tool unclutter, but using the x11-xfixes extension."
+AUTHOR = "Ingo Bürk"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b25d2c4cca175f44120d1b8e67cb358d"
+
+SRC_URI = "git://github.com/Airblader/unclutter-xfixes.git \
+ file://0001-build-use-autotools.patch"
+SRCREV = "10fd337bb77e4e93c3380f630a0555372778a948"
+
+inherit autotools pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+DEPENDS = "libev libx11 libxi libxfixes"
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ # LICENSE is installed to /usr/share/licenses but we don't want it in the package
+ rm -rf ${D}${datadir}
+}