aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/ttf-fonts
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-02-13 14:52:07 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:46 +0100
commita0d02d55b4336551eefbe727e625e7369e2ac321 (patch)
tree0ee027377fdb9b2482fc5e202a6ad3a86d50730e /meta-oe/recipes-graphics/ttf-fonts
parent841ecdc58dd1d920d327fe4c7a29a6f8e7ba8857 (diff)
downloadmeta-openembedded-contrib-a0d02d55b4336551eefbe727e625e7369e2ac321.tar.gz
source-han-sans-tw-fonts: initial add 1.004
Based on [1-2]. [1] https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/adobe-source-han-sans-fonts [2] http://pkgs.fedoraproject.org/cgit/rpms/adobe-source-han-sans-tw-fonts.git/tree/adobe-source-han-sans-tw-fonts.spec Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/ttf-fonts')
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/source-han-sans-tw-fonts/44-source-han-sans-tw.conf19
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/source-han-sans-tw-fonts_1.004.bb34
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-tw-fonts/44-source-han-sans-tw.conf b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-tw-fonts/44-source-han-sans-tw.conf
new file mode 100644
index 0000000000..ae289401bb
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-tw-fonts/44-source-han-sans-tw.conf
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
+<fontconfig>
+ <!--
+ - Medium variant is used instead of Regular on Qt apps:
+ https://bugs.launchpad.net/ubuntu-font-family/+bug/744812
+ - Medium and Bold looks the same in certain applications:
+ https://bugs.launchpad.net/ubuntu/+source/gnome-specimen/+bug/813373
+ -->
+ <match target="scan">
+ <test name="fullname" compare="eq">
+ <string>Source Han Sans TWHK Medium</string>
+ </test>
+ <edit name="weight" mode="assign">
+ <const>demibold</const>
+ </edit>
+ </match>
+</fontconfig>
+
diff --git a/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-tw-fonts_1.004.bb b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-tw-fonts_1.004.bb
new file mode 100644
index 0000000000..728250538d
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-tw-fonts_1.004.bb
@@ -0,0 +1,34 @@
+require ttf.inc
+
+SUMMARY = "Adobe OpenType Pan-CJK font family for Traditional Chinese"
+HOMEPAGE = "https://github.com/adobe-fonts/source-han-sans"
+LICENSE = "OFL-1.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55719faa0112708e946b820b24b14097"
+
+inherit allarch fontcache
+
+# Download tends to break - so - or not?
+#EXCLUDE_FROM_WORLD = "1"
+
+SRC_URI = " \
+ https://github.com/adobe-fonts/source-han-sans/raw/release/SubsetOTF/SourceHanSansTW.zip \
+ file://44-source-han-sans-tw.conf \
+"
+SRC_URI[md5sum] = "6533b71b31c19e548768f0fc963202f3"
+SRC_URI[sha256sum] = "92ba161921c5cdec5a8f8d5711676f0865b50cee071c25eb4bd4125b5af59fd0"
+
+S = "${WORKDIR}/SourceHanSansTW"
+
+do_install() {
+ install -d ${D}${sysconfdir}/fonts/conf.d/
+ install -m 0644 ${WORKDIR}/44-source-han-sans-tw.conf ${D}${sysconfdir}/fonts/conf.d/
+
+ install -d ${D}${datadir}/fonts/truetype/
+ find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
+}
+
+FILES_${PN} = " \
+ ${sysconfdir}/fonts \
+ ${datadir}/fonts \
+"
+