aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/ttf-fonts
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2016-03-21 12:58:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-25 11:27:29 +0100
commit92c5f5594e32ad9f8f63b00493a0ba1211a930c8 (patch)
treefd6e1b62d57c4c6fd280b9b86f7aae41c85d67f6 /meta-oe/recipes-graphics/ttf-fonts
parent9b7f8e35e1f0708cae4c3d8e62689f6255d03a2d (diff)
downloadmeta-openembedded-contrib-92c5f5594e32ad9f8f63b00493a0ba1211a930c8.tar.gz
ttf-pt-sans: add recipe
PT Sans is an open source licensed font released in 2010 by ParaType. The ParaTypeFFL-1.3 license file has been submitted to OE-core. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/ttf-fonts')
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-pt-sans_1.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-pt-sans_1.1.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-pt-sans_1.1.bb
new file mode 100644
index 0000000000..ac60a365f0
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-pt-sans_1.1.bb
@@ -0,0 +1,39 @@
+SUMMARY = "PT Sans Fonts"
+DESCRIPTION = "The PT Sans TTF font set"
+HOMEPAGE = "http://www.paratype.com/public/"
+
+SECTION = "x11/fonts"
+
+LICENSE = "ParaTypeFFL-1.3"
+LIC_FILES_CHKSUM = "file://../PT%20Free%20Font%20License_eng.txt;md5=d720f3a281ed81c3f4cfc465e11b1d0d"
+
+inherit allarch fontcache
+
+# Downloading from fedora because upstream doesn't version its zip file
+# and causes hash build failures
+SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/paratype-pt-sans-fonts/PTSans.zip/c3f5a0e20a75cf628387510a720924a7/PTSans.zip"
+
+SRC_URI[md5sum] = "c3f5a0e20a75cf628387510a720924a7"
+SRC_URI[sha256sum] = "0164f824e03c32c99e8a225853ec168893a04a09ade132e93a674e85ae033b2e"
+
+do_install () {
+ install -d ${D}${datadir}/fonts/X11/TTF/
+ cd ..
+ for i in *.ttf; do
+ install -m 0644 $i ${D}${prefix}/share/fonts/X11/TTF/${i}
+ done
+}
+
+FILES_${PN} += "${datadir}"
+
+pkg_postinst_${PN} () {
+ set -x
+ for fontdir in `find $D/usr/lib/X11/fonts -type d`; do
+ mkfontdir $fontdir
+ mkfontscale $fontdir
+ done
+ for fontdir in `find $D/usr/share/fonts/X11 -type d`; do
+ mkfontdir $fontdir
+ mkfontscale $fontdir
+ done
+}