aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/packagegroups
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-09-04 14:33:50 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-05 10:05:06 +0200
commit49e269ecc66adda341922cbd86167bbfa97c54ca (patch)
treec8a49f67708832dc9aa613bb45ef62c06d9a0c62 /meta-oe/recipes-graphics/packagegroups
parent21a4be0e36bb1ee6c3c469c83a623c5d9a45257a (diff)
downloadmeta-openembedded-contrib-49e269ecc66adda341922cbd86167bbfa97c54ca.tar.gz
packagegroup: add RPROVIDES/RREPLACES/RCONFLICTS and bump PR to get some upgrade path
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/packagegroups')
-rw-r--r--meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb22
1 files changed, 17 insertions, 5 deletions
diff --git a/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
index 816a67f593..76126fc81c 100644
--- a/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
+++ b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
@@ -3,7 +3,7 @@ SECTION = "fonts"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
PV = "1.0"
-PR = "r1"
+PR = "r2"
inherit packagegroup allarch
@@ -12,14 +12,26 @@ PACKAGES += "\
${PN}-chinese \
${PN}-japanese \
"
+RPROVIDES_${PN} += "task-fonts-truetype"
+RPROVIDES_${PN}-core += "task-fonts-truetype-core"
+RPROVIDES_${PN}-chinese += "task-fonts-truetype-chinese"
+RPROVIDES_${PN}-japanese += "task-fonts-truetype-japanese"
+RREPLACES_${PN} += "task-fonts-truetype"
+RREPLACES_${PN}-core += "task-fonts-truetype-core"
+RREPLACES_${PN}-chinese += "task-fonts-truetype-chinese"
+RREPLACES_${PN}-japanese += "task-fonts-truetype-japanese"
+RCONFLICTS_${PN} += "task-fonts-truetype"
+RCONFLICTS_${PN}-core += "task-fonts-truetype-core"
+RCONFLICTS_${PN}-chinese += "task-fonts-truetype-chinese"
+RCONFLICTS_${PN}-japanese += "task-fonts-truetype-japanese"
-RRECOMMENDS_packagegroup-fonts-truetype = "\
+RRECOMMENDS_${PN} = "\
${PN}-core \
${PN}-chinese \
${PN}-japanese \
"
-RDEPENDS_packagegroup-fonts-truetype-core = "\
+RDEPENDS_${PN}-core = "\
fontconfig-utils \
\
ttf-dejavu-common \
@@ -28,12 +40,12 @@ RDEPENDS_packagegroup-fonts-truetype-core = "\
"
# ttf-dejavu-serif \
-RDEPENDS_packagegroup-fonts-truetype-chinese = "\
+RDEPENDS_${PN}-chinese = "\
${PN}-core \
ttf-arphic-uming \
"
-RDEPENDS_packagegroup-fonts-truetype-japanese = "\
+RDEPENDS_${PN}-japanese = "\
${PN}-core \
ttf-sazanami-gothic \
ttf-sazanami-mincho \