aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/packagegroups
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-09-04 14:11:58 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-05 10:05:06 +0200
commit21a4be0e36bb1ee6c3c469c83a623c5d9a45257a (patch)
treebe14375786b4756c8c9d62020cc99a8b2da808fa /meta-oe/recipes-graphics/packagegroups
parentf3dbc97b44a5dd2588eb0c6ed7e3ce1b1e997847 (diff)
downloadmeta-openembedded-contrib-21a4be0e36bb1ee6c3c469c83a623c5d9a45257a.tar.gz
task*: rename to packagegroup to match oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/packagegroups')
-rw-r--r--meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
new file mode 100644
index 0000000000..816a67f593
--- /dev/null
+++ b/meta-oe/recipes-graphics/packagegroups/packagegroup-fonts-truetype.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Install one of these tasks to get support for truetype fonts."
+SECTION = "fonts"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PV = "1.0"
+PR = "r1"
+
+inherit packagegroup allarch
+
+PACKAGES += "\
+ ${PN}-core \
+ ${PN}-chinese \
+ ${PN}-japanese \
+"
+
+RRECOMMENDS_packagegroup-fonts-truetype = "\
+ ${PN}-core \
+ ${PN}-chinese \
+ ${PN}-japanese \
+"
+
+RDEPENDS_packagegroup-fonts-truetype-core = "\
+ fontconfig-utils \
+ \
+ ttf-dejavu-common \
+ ttf-dejavu-sans \
+ ttf-dejavu-sans-mono \
+"
+# ttf-dejavu-serif \
+
+RDEPENDS_packagegroup-fonts-truetype-chinese = "\
+ ${PN}-core \
+ ttf-arphic-uming \
+"
+
+RDEPENDS_packagegroup-fonts-truetype-japanese = "\
+ ${PN}-core \
+ ttf-sazanami-gothic \
+ ttf-sazanami-mincho \
+"