aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/openbox
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-10-12 10:13:12 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-19 11:42:13 +0200
commit8402b7ac0f2e3b0afd9d56e16e7935e1887c7698 (patch)
treea91a90f104a11aa51c5abc40c3dfd4972f735881 /meta-oe/recipes-graphics/openbox
parent4cd60deb11a8a6f9134d7f6ec39255a35d921426 (diff)
downloadmeta-openembedded-contrib-8402b7ac0f2e3b0afd9d56e16e7935e1887c7698.tar.gz
PACKAGES_DYNAMIC: use regexp not glob
* bitbake uses PACKAGES_DYNAMIC as regexp ^ could make matching faster (and it will be more clear that we're expecting regexp not glob) * made all those last '-' optional, use .* (or nothing) * use += instead of = in most cases to keep ${PN}-locale from bitbake.conf:PACKAGES_DYNAMIC = "^${PN}-locale-.*" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/openbox')
-rw-r--r--meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
index 0d03889884..8e842c48fe 100644
--- a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
+++ b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
@@ -20,7 +20,7 @@ EXTRA_OECONF += "--with-plugins=none"
PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome"
-PACKAGES_DYNAMIC += "${PN}-theme-*"
+PACKAGES_DYNAMIC += "^${PN}-theme-.*"
python populate_packages_prepend() {
theme_dir = bb.data.expand('${datadir}/themes/', d)