aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lxdm
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-04-24 15:21:24 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-26 10:00:33 +0200
commitdefabe7408915c10b6df520247fa966ad0260846 (patch)
tree151355365b3e2235e24db292c298ff07a0df2e94 /meta-oe/recipes-graphics/lxdm
parent003565af7a952dd8d0646e1b59aff1ae568c9ddf (diff)
downloadmeta-openembedded-contrib-defabe7408915c10b6df520247fa966ad0260846.tar.gz
lxdm: fix postinst-code
Exiting postinst code leaves systemd.bbclass offline postinst code unexecuted, causes postinst not to finish at first boot (lxdm.service is not aliased to display-manager.service -> started much too early) and is not neccesary: language preparation can be done offline. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lxdm')
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb21
1 files changed, 9 insertions, 12 deletions
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
index a24f75c654..6675691e60 100644
--- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -15,7 +15,7 @@ LXDM_PAM = "${@base_contains("DISTRO_TYPE", "debug", "lxdm-pam-debug", "lxdm-pam
SRCREV = "65e7cc8fdc150c2b925eb348ce82de17dee5eb0b"
PV = "0.4.2+git${SRCPV}"
PE = "1"
-PR = "r6"
+PR = "r7"
DEPENDS = "cairo consolekit dbus gdk-pixbuf glib-2.0 gtk+ virtual/libx11 libxcb pango"
@@ -49,19 +49,16 @@ do_install_append() {
# make installed languages choosable
pkg_postinst_${PN} () {
-if [ "x$D" != "x" ]; then
- exit 1
-fi
langs=""
-for lang in `find ${libdir}/locale -maxdepth 1 | grep _ | sort`; do
- lang=`basename $lang`
- if [ "x$langs" = "x" ]; then
- langs="$lang"
- else
- langs="$langs $lang"
- fi
+for lang in `find $D${libdir}/locale -maxdepth 1 | grep _ | sort`; do
+lang=`basename $lang`
+if [ "x$langs" = "x" ]; then
+ langs="$lang"
+else
+ langs="$langs $lang"
+fi
done
-sed -i "s:last_langs=.*$:last_langs=$langs:g" ${localstatedir}/lib/lxdm/lxdm.conf
+sed -i "s:last_langs=.*$:last_langs=$langs:g" $D${localstatedir}/lib/lxdm/lxdm.conf
}
RDEPENDS_${PN} = "pam-plugin-loginuid setxkbmap"